Running Cadence
Once the Cadence environment has been setup you can start working with Cadence. You
can run cadence from your directory by typing

X wterm (172.26.1.1 wia TELNET) -0 x|

czulbervly zource setpath, ichd
caulbzruly icfb &

Figure 1.

Main window (Common Interface Window), CIW opens and from the pull down menus
you can start your design.

% icfb - Log: /home; atodri/CDS.log o ] [
File Tools Options Help 1

This library is provided as an education medium. It is
based upon the generic process awailable thru Cadence POE
factory in the GPDK Process Delivery Kit.

Cadence shall in no case be liable for the contents of
this likhrary.
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Figure 2.

To create your own library, select from File-> New -> Library, the pop-up window
shows up as shown in the Figure 3.




x|
oK | Cancel | Defaultsl Apply |

Help
Library Technology File
Namea II If you will be creating mask layout or
) N " " other physical data in this library, you
Directory (non-library directories) )
/| will need a technology file. If you plan
T | | | touse only schematic or HDL data, a
LYs technology file is not required.
Mail
SI_stuff “# Compile a new techfile
SeiFun i ~~ Attach to an existing techfile
/home fatodrd ~ Don’t need a techfile
Design Manager Mo DM — |
Figure 3.

In the Name section write the name of library. You need add a technology file to your
new library. You can attached or compile a tech file to the library. In this case you will
attach an existing tech. file. You can attach the technology file from the “gpdk” library as

shown in the Figure 4.

% Attach Design Library to Technology File il
0K | Cancel | Defaultsl fpply | Help
By Dhonha Ewary IEKE'IﬂPlE
Technology Library gpdk —
Figure 4.

After creating the working library, you can start creating various views to simulate your

design.




-V Characteristics of Diode

First we start by creating the new cell view for the diode. From File-> New -> Cellview

x
Ok Cancel | Defaults Help

Library Hame EE330
cell Name cesitl
View Hame schematic
Tool Composer- Schematic
Library path file
Jhome fatodrifeds. ik

Figure 5.
This creates the schematic view as shown in the Figure 5. You will be using a voltage

supply, resistor, and a diode to create the schematic view as shown in the Figure 6.

[¥ ¥Yirtuoso® Schematic Editing: EE330 test1 schematic - C -0 x|
Cmd: Sel: 0 Status: Ready T=27 C Simulator: spectre 3

Tools Design Window Edit Add Check Sheet Options Help

€% | [
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moseL: museSSlct - : S R:

% |5z 2]
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Figure 6.



To add any of the components in the schematic:

From Add-> Instance ->

[% Add Instance x|

Hide | Cancel | Defaultsl Helpl
Library gpdq Browse |
Cell | ndic

View I symhol:

Hames I

Array Rows Il Columns Il
Rotate I Sidewrays I Upside Duwnl

sndel nams |dinn
Bovins aea I le-12
Multiplier |1
Length (M) Ilu it}
Width (M) Ilu ']
Figure 7.

Select the diode, voltage supply, resistance and ground as shown in the Figures 7, 8, 9
and 10.



i% Add Instance x|

Hide | Cancel | Defaultsl Help

Library I analogLiby Browse I
cell | vda
View I symboli

Hames I

frray Rows Il Columns Il
Rotate I Sideways I Upside Duwnl

AC magnitude |
AC phase I
DC voltage |3

Hoise file nanme

Humhber of noiseffreq pairs I':E

=

Figure 8.




i% Add Instance x|

Hide | Cancel | Defaultsl Help
3
Library | an=logLib Browsse |
cell |res
View Iﬁ?mbﬂﬂ
Hames I
furay Rowrs Il— Columns Il—

Rotate I Sideways I Upside Duwnl

Resistance I 1K Ohmg

Temperatu
Temperatu

Model nan

re coefficient 1 I

re coefficient 2 I
e I
i

¥ Add Instance x|

Figure 9.

Hide | Cancel | Defaultsl Helpl
Library | an=logLib Browse |
cell | gnd
View IS?meﬂ
Hames I
Array Rows Il Columns Il

Rotate I Sideways I Upside Duwnl

Figure 10.




Place the components as shown in the Figure 6. At this point you are ready to start the
simulation.

From Tools-> Analog Environment

% Cadence® Analog Design Environment (1) - |EI|£|
Status: Ready T=27 C Simulator: spectre 5
Session Setup Analyses Vadables Outputs Simulation Results Tools Help
Design Analyses
Lib EFE 330 #  Type Argquments. ... L L
Cell testl 1 dc 1] 3 100m  Line. .
View  schematic
Design Variables Outputs [E:
#  MName Value #  Name/Signal/Expr Value Plot Sawve March y
1  RO/MINUS YES YES o —_—
2 neth ves allv no
3 D1/PLUS ¥es Yes no
4  [1/MINUS ¥es Yes no
: Y
Figure 11.

Write the path for the model libraries

x
OK | Cancel | Defaultsl Apply | Help
IModel Library File Section
swock/gpdk MIET 2. 0/gpdks. . /models/gpdk. scs HH
Model Library File Section {opt.)
add | Delete Change Edit File | Browse... |

Figure 12,



Choose dc type of analysis from Analysis -> Choose

"% Choosing Analyses - Cadence® Analog Design Envira

oK | Can[:ell Defaultsl .prlyl

Analysis - tran # dc

W AL

- Noise

~ o KT ~ SENS -~ dcmatch - - sth

s S - Bnvip PSS - pac

~- pnoise . pxrf -~ Psp - PSS

- (pac ~s gpnoise .- qpxf ~ (P3P
DC Analysis

Save DC Operating Point -

Sweep Variabhle

_| Design VYariahle

| ¥ii
_I Temperature Component Hame ]

Select Component

_| Model Parameter

W component Parameter  parameter Name Idc'i

Sweep Range

Sweep Type

Add Specific Points |

“# Step Size

Linear I ~ Humber of Steps

# Start-Stop - -
Start | I Sto | k!
- Center-Span : Po=

0.1

Enabled W

Options... I

Figure 13.




Variables to be plotted are selected from the schematic

setup ...

Delete

To Be Saved

T B Marohod Select On Schematic
To Be Plotted Add To

Save All ... Remove From

Figure 14.

To plot voltages select the wire, and to plot current select the red square nodes or select
on the component. Figure 15 shows how the selected voltages and current nodes look
line after being selected for simulation.

[X ¥irtuoso® Schematic Editing: EE330 testl schematic - -10O] x|
Cimid: Sel: 0 Status: Selecting outputs to be pl 727 ¢ Simulator: spectre 3
Tools Design Window Edit Add Check Sheet Options Help

<% | K

)
/LN

0
M

mu:useL: museSSlct - : - R:

= modify_plot

Figure 15.




Now we are ready to perform simulation. After clicking on Simulation-> Netlist and Run

simulation starts.

Figure 16, shows the spectre output log file that gets generated for simulation.

% /home/atodri/simulation/test1 /spectre /schematic, - | Ellﬂ
File Help | 27
Total time required for dc analysis “deo’ was 20 ms.
modelParameter: writing model parameter walues to rawfile.
element: writing instance parameter walues to rawfile.
outputParameter . writing output parameter walues to rawfile.
designParamWals: writing netlist parameters to rawfile.
b bbb ok
OC Analysis “dc’: ¥O:dc mw-x3W
FEFEEEFE AT EE LTI AT LI LI L TR EL AL R LTS
Inportant parameter walues:
reltol = 1=-03
shatol (W) = 1 u¥
abstol(I) = 1 pa
temp = 2T
tnom = 2T C
tempeffects = all
gmin = 1 ps
deo: de = 100 m¥ (3,33 %), step = 100 m¥ (3,33 %)
de: deo = 300 my (10 %), step = 100 m¥ (3.33 )
do: do = 400 m¥ (13.3 %), step = 100 m¥ (3.33 %)
do: do = 600 my (20 %), step = 100 m¥ (3.33 =
deo: de = 700 mW (23,3 %), step = 100 m¥ (3,33 %)
de: deo = 900 my (30 %), step = 100 m¥ (3.33 )
de: dec = 1 ¥ (33.3 %), step = 100 m¥ (3.33 %)
do: doc = 1.2 ¥ (40 %), step = 100 m¥ (3.33 %)
de: de = 1.3 ¥ (43,3 %), step = 100 m¥ (3,33 %)
de: de = 1B ¥ (50 %), step = 100 m¥ (3,33 %)
de: doc = 1B ¥ (53.3 %), step = 100 m¥ (3,33 %)
do: doc = 1.8 ¥ (60 %), step = 100 m¥ (3.33 %)
de: doc = 1.9 ¥ (3.3 %), step = 100 m¥ (3.33 %)
de: de = 2.1 ¥ (T0 %), step = 100 m¥ (3,33 %)
do: doc = 2.2 ¥ (73,3 %), step = 100 m¥ (3,33 %)
do: do = 2.4 ¥ (80 %), step = 100 m¥ (3.33 %)
de: doc = 2.5 ¥ (83.3 %), step = 100 m¥ (3.33 %)
de: de = 2.7 ¥ (A0 %), step = 100 m¥ (3,33 %)
do: do = 2.8 ¥ (93,3 %), step = 100 m¥ (3,33 %)
do: do = 3 ¥ (100 %), step = 100 m¥ (3.33 %)
Total time required for do amalysis *de’ was 50 ms.
modelParameter: writing model parsmeter values to rawfile.
element: writing instance parameter walues to rawfile.
outputParameter: writing output parameter walues to rawfile.
designParamVals: writing netlist parameters to rawfile.
=S NI - - A s .. | o | o | . | . | o _ IL
Figure 16.
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The waveform created looks like :

% Waveform Window 11 -- Cadence® Analog Desig - |El|ﬂ
Active 32
Window Foom Axes Curves Markers Annotation Edit Tools Help

EEAAE testl s

mouse L:awvMouseleleteSelec M: R:

= modify_plot

Figure 17

To display Current (1) versus Voltage (V) we start by setting the axis.
From Axis-> X AXxis

x

oK Cancel | Defaults| Apply Help

Lahel Default |dc [ ¥ )

Style 4 futo Linear Log

Range 4 Auto
Min- kax

Plot ¥s. independent wvariable

Figure 18.
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Change the X axis to be the voltage drop on the diode or /net5 voltage as shown in the
Figure 19.

]
oK Cancel | Defaults, Apply Help
Label (I Default | de ( ¥ )

Style % puto Linear Log

Range 4 Auto
Min- Max

Flot vs. 3 /nets

Figure 19.

After changing the X axis, the waveform looks like, as shown in Figure 20:

% Waveform Window 11 -- Cadence® Analog Desig - |EI |ﬂ
Active 32

Windows Ffoom Axes Curves Markers Annotation Edit Tools Help

mouse L:aweiouseleleteselec M: E:

= modify _plot

Figure 20.
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Because we are interested only on the I-V plot for the current and voltage of the diode,
we can select only the D1/PLUS current node and /net5 voltage drop of the diode. The
new waveform will look like shown in Figure 21.

% Waveform Window 10 -- Cadence® Analog Desig - |EI |ﬂ
Active 28
Windows Ffoom Axes Curves Markers Annotation Edit Tools Help

it = Jul 14 11:15:29 2EGES

D Response

mouse L:awvMouseleleteSelec M: R:

= modify_plot

Figure 21.
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-V Characteristics of BJT

Initially start a new schematic cellview for the bjt circuit. Figure 22, displays the circuit
used for simulation. After adding all the necessary components, connect them together
and the last part is editing the variables.

The power supply “vdc” is identified with a variable voltage “VBB”. You can do this by
editing the properties of the power supply.

¥ Virtuoso® Schematic Editing: EE330 testZ schematic -- Cade =10 =l
Cmd: Sel: 0 Status: Ready T=27 C Simulator: spectre 33

Tools Design Window Edit Add Check Sheet Options Help

A& E

mouse L. mouseSubSelectPt M: R:

Figure 22.

After complting the schematic, we are ready to start simulation.

From Tools -> Analog Enviroment, and the pop-up window as in Figure 23 shows up.
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% Cadence® Analog Design Environment (2)

-0l x|
Status: Ready T=27 C Simulator: spectre 34
session Setup Analyses Varables Outputs Simulation Results Tools Help
Design Analyses '—i{
Lib FE330 Type Brouments. ... ... L. Enable 4 ?}Enn
Cell test? dc -2 5 huto. . Star.. yes 2fe
1]z
i 711
View  schematic vz
Design Variables Outputs [E:
#  Mame Value Name /Signal Expr ¥alue  Plot Sawe March y
1 ¥EBE 5 —_—
} Y
Figure 23.
Setting the Variables

% Editing Design Yariables -- Cadence® Analog Design En¥ironn

OK | Cant:ell Apply | Apply & Run Simulation

R
Help

Selected Yariahle

Table of Design Variahles

R I VEE #  Hame Value
Value (Expr) |5 1 VBB 5
Pwldl Delete Changel Hextl Clearl Fmdl
Cellview Variables Copy Fruml Copy Tul
Figure 24.
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Setting the type of Analysis

% Choosing Analyses - Cadence® Analog Design Envi El
oK | Can[:ell Defaultsl .prlyl Help
Analysis - tran “# dc - ac -~ hoise

~ o KT ~ SENS -~ dcmatch - - sth

s S - Bnvip PSS - pac

~- pnoise . pxrf -~ Psp - PSS

- (pac ~s gpnoise .- qpxf ~ (P3P
DC Analysis

Save DC Operating Point -

Sweep Variabhle
| SVL
_| Temperature Component Hame !

_I Design Variable Select Component |

W component Parameter  parameter Name Idc'i

_| Model Parameter

Sweep Range
# Start-Stop -
Start I— Sto IE
- Center-Span 1 Po=
Sweep Type

Automatic I

Add Specific Points |

Enabled W Options... I

Figure 25.

After completing these steps you can start simulation by clicking on

Simulation-> Netlist and Run.

At this point you can see the spectre output log file that is created.

After this point you will perform parametric analysis as shown in Figure 26, to view
multiple curves in a single waveform.



X1 Parametric Analysis - spectre(1): EE330 test2 schematic

Tool Setup Analysis

=10l x|

Help | 58

Sweep 1 Variable Name | VEE Add Specification
Range Type FromTo From (O
. — Select
Step Contrpl ~ Unear Steps Step Size it
Figure 26.

Go to Analysis -> Start in the Parametric Analysis window. When the simulation is
complete go to Results -> Direct Plot -> DC and then click on the terminal of the V1
supply, then hit ESC. Now you should again get a nice family of IV curves as shown in

Figure 27.

% Waveform Window 8 -- Cadence® Analog Design Environme

Window ZFoom Axes Curves Markers Annotation Edit Tools
EESSE t

schematic :

mouse L:awviouseleleteSelectPtCE( M:

>

Jul 14 TR 4317

=10l x|

Active B0

Help

Figure 27.
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Generating C-V Plots for MOS Capacitor Device

[X ¥irtuoso® Schematic Editing: EE330 test3 schem =10l x|

Cmd: Sel: 0 Status: Ready T=27 C Simulator: spectre
Tools Design Window Edit Add check Sheet Options

AR

mouse L: mouseSubSelectPt M E:

62
Help

Figure 28.
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% Cadence® Analog Design Environment {4)

Status: Ready

T=27¥ C Simulator: spectre 63

session Setup Analyses Varables Outputs Simulation Results Tools

=10l x|

Help

Design Analyses '—i{
Library EE330 # Type Brouments. ... ... L. Enahble m
Cell testd 1 de t =B 2 duto.. wes . '?E -
View  schematic i 'i I

Design Variables Outputs

#  Mame Value #  Name/Signal/Expr ¥alue  Plot Sawe March
1 w0 -2

= Results in fhomefatodrifsimulationftest3fspectrefschematic

Figure 29.
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"% Choosing Analyses - Cadence® Analog Design Enviro 5[

0K | Can-::ell Defaultsl prlyl Help
Analysis - tran # dc - ac -~ hoise
o Kf - SBNS - dcmatch - - sth
o S - Bnvip - PSS o pac
~- phoise . pxf -~ Psp ~ [pss
= qpac “s gpnoise - qpxr =~ QP3P
DC Analysis

Save DC Operating Point W

Sweep Yariahle

_| Temperature
W Design Variahle Variable Mame | ¥0

_| Component Parameter Select Design Variable |
_| Model Parameter

Sweep Range
# Start- Stop - -
Start I—E Sto IE
- Center- Span E po=
sSweep Type

Automatic I

&dd Specific Points  _J

Enabled W Options... I

Figure 30.
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% Editing Design Yariables - Cadence® Analog Design Environ El

Ok | Can[:ell Apply | Apply & Run Simulation

Help

selected Yariahle

Tahle of Design Variabhles

Hame I- #  Hame Value
Value {Expr) F 1 v -2
Pu:ldl Deletel Changel Hextl Clearl Fmdl
Cellview Varables Copy Fruml Copy Tul
Figure 31

Perform simulation from Simulation -> Netlist and Run

Hetlist and Run

Run

Hiams

Options -
Hetlist -
Qutput Loy ...
Converjgence Alds -
Metlist and Debug AHDL
Debug AHDL

Figure 32

Then perform Parametric Analysis
Parametric Analysis ...
Comers ...

Monte Caro ...

Yield Analysis ...
Optimization ...

RF -
Calculator ...

Results Browser ...

Waveform ...
Results Display ...
Jobh Monitor ...

Figure 33
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% Parametric Analysis - spectre(3): EE330 test3 schematic - |EI|5|

Tool Setup Analysis Help | 65

Sweep 1 Variable Hame | 78 Add Specification |

Range Type M From I -4 To

_ Select _J
Step Control Ao | qorar steps ||
Figure 34
Parametric Analysis Form
Select output to be displayed: From Output -> Setup
Setup ...
frrinis
To Be Saved -
Fo B Rarchod o
To Be Plotted -
Save Al ... .
Figure 35
The Form will look like:
% Setting Outputs -- Cadence® Analog Design Environment (4) ﬂ
oK | Cancell Apply | Help
Selected Output Table Of Outputs
Mame {opt.) F ”# Name /Signal Expr ¥alue Plot Save March

Expression I

Calculator Openl Get Expressiunl Clusel

vill Be B Plotted/Evaluated

Mdl Deletel Cha.ngel Nextl Hew Expressiunl

Figure 36
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By clicking on “Open” , the Calculator will open

=

Window Memories Constants Options Help | 67
A

| J,

Evaluate Buffer _| Display Stack _| # standard -, RF

hmwserl vt | it | Iastxl xuyl dwnl up | sto | rcl | Special Functions —'l
wave | T | if | clear | clstl app | sin | asinl magl In | exp | ahsl
Tamily | Vs | is | enter | undul eex | Cos | ax:usl phasel Iug1l]| 1I]**x| int |
erplot | vdc| e | - | 7 | 8 | 9 | tan| atan| real| aBi0| yrx| 1ix |
piot || op | opt|| + | 4| 5 | & | sinh|asinh| imag| aB20| x2| sqrt|
printvsl vnﬁvarl v | 1 | 2 | 3 | cushlax:usli fl | L4 | T3 | T4 |
print || mp |\ t | o | . | + | tanh|atanhl

\

\ Figure 37

By clicking on “ OP”
see a list of variables

and then selecting the device from the schematic view, you will

[% OP parameters for CO x|

Ok | Cant:ell

Helpl

List

Figure 38
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List
cap
cdy
cgh
ids
Vs
vils
vhs
vth
vidsat
gm
gds
gmbs
betaeff
cjd
cjs
cqy
cod
Cis
gmoverid
chy
cdd
cis
cdb
Csy
csd
CSS
csh
pwr
chd
chs
chh

QM

Figure 39
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After selecting the variables to be plot, then just click on ERPLOT in the Calculator to

plot.

1o/
Window Memories Constants Options Help | &7
Jrop ¢t o0, "oghty-0P (" fo0", "egd") -0B (" /0", "ogs") ) S35 Af j

£

Evaluate Buffer _| Display Stack _| “# standard ~ RF
hmwserl vt | it | Iastx' xuy' uwn| up | sto | rcl | Special Functions —'|

wave | VT | if | clear | clstl appl sin | asinl magl In | Expl ahsl
family | Vs | is | enter | undu' eex | cos | ax:us' phasel Iug1l]| 1I]**x| int |
erplot | vac| e | - | 7 | 8 | 9 | tan| atan| real| dB10| y*rx| 1ix |
piot || op | opt|| + | 4| 5 | & | sinh|asinh| imag| dB20| x*2| sqrt|
printvsl vnlvarl *| 1 | 2| 3|cush|ax:usl’1 f1| f2| f3| f4|
print || mp | t | 0| . | + | tanh|atanhl

Figure 39

The waveform will look like:
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%]

Active

Help

Window ZFoom Axes Curves Markers Annotation Edit Tools

mouse L: awvMouseDeleteSelectPtCE ()

>

Figure 40
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Active  6d
Window ZFoom Axes Curves Markers Annotation Edit Tools Help
A
P

mouse L: awvMouseDeleteSelectPtCE ()

>

Figure 41
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Variation of the Bandgap Reference Voltage with respect to Temperature

The example below is the classical Widlar Bandgap Voltage Reference

X! ¥irtuoso® Schematic Editing: EE330 temp_test schematic -- Cadence® Analog Desig -0 ﬂ
Cmd: Sel: 0 Status: Ready T=27 C Simulator: spectre 3
Tools Design Window Edit Add Check Sheet Options Help

<% [

P
V=8

0]
™o

%
)

mouse L: mouseSubSelectPt

>

Figure 42
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By clicking on Tools -> Analog Environment

% Cadence® Analog Design Environment (1) - |I:I|5|
Status: Ready T=27 C Simulator: spectre 4
session Setup Analyses Varables Outputs Simulation Results Tools Help

Design Analyses '—i{
Lib EF330 #  Type Argquments. ...
Cell temp_test 1 de -E0 120 50 Line. .
View  schematic
Design Variables Outputs [E:
#  Mame Value #  Name/Signal/Expr ¥alue  Plot Sawe March y
1 neth ves allwy no —_—
2  net025 yes allv no
: Y
Figure 43.

The type of analysis is dc as in Figure 44.
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"% Choosing Analyses - Cadence® Analog Design Env¥iro El

oK | Can[:ell Defaultsl .prlyl Help
Analysis - tran “# dc - ac -~ hoise
~ o KT ~ SENS -~ dcmatch - - sth
s S - Bnvip PSS - pac
~- pnoise . pxrf -~ Psp - PSS
- (pac ~s gpnoise .- qpxf ~ (P3P
DC Analysis

Save DC Operating Point -

Sweep Variabhle

W Temperature

_| Design VYariahle

_| Component Parameter
_| Model Parameter

Sweep Range

Linear I “# Number of Steps

Add Specific Points |

# Start-Sto .
P start -6 Stop
+ Center- Span
sweep Type
PR -~ aiep Size

e

Enabled W

Options... I

Figure 44
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The output signals to be observed during the simulation are:

X! ¥irtuoso® Schematic Editing: EE330 temp_test schematic -- Cadence® Analog Desig
Cmd: Sel: 0 Status: Selecting outputs to be plotted...

Tools Design Window Edit Add Check Sheet Options

<% [

P
V=8

0]
™o

%
)

=

I

I

abc

mouse L: mouseSubSelectPt M:
> modify_plot

O || é v

=101 ]

T=27 C Simulator: spectre

3

Help

Figure 45

To start simulation from click on “Netlist and Run”
Metlist and Run
Run
Hiom
Options
Hetlist
Output Log ...
Converjgence Aids
Metlist and Debug AHDL

Debug AHDL Figure 46
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The waveforms for the output signals as we perform dc analysis on variable temperature:

% Waveform Window 2 -- Cadence® Analog Design E - |EI |ﬂ
Active 11

Windows Ffoom Axes Curves Markers Annotation Edit Tools Help

EEZ3E termp_test schemoatic @ Aug 26 15:458

D Re:

mouse L:aweiouseleleteselec M: E:

=

Figure 47
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Bandgap Temperature Reference (\Version 2)

Figure 48
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=8l

Active 12

Ixi Waveform Window 5 - Affirma Analog Circuit Design Environment {1}

VWindow Zoom Axes Curves Markers Annotation Edit Tools Help

R: awviAxisMeruCB()

mouse L: awvMouseSingleSelectPtCB() M:

Bistart| 8 DS T @A 0@ [EE & 4 D[ 5 ¢ [x)xdient Mana... ||(x)8 Reflectio... » ] Documentt - ... | |4 @, 10:55 M

Figure 49
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L e L e b e e e L e e e 2 e e

0 T S S S S S [ S U S (S TR I

: awviMouseSingleSelectPtCB( ) R: sevPlotAllOutputs(’ sevSessionl)

Figure 50
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Single Stage Amplifiers

[X| ¥irtuoso® Schematic Editing: EE330 amplifier schematic - Cade =10 ﬂ
Cmd: Sel: 0 Status: Ready T=27 C Simulator: spectre 3
Tools Design Window Edit Add Check Sheet Options Help

2=

0]
™

y | TEusE L: mouseSubSelectPt H: R:

»

Figure 51

This is a common-source single-transistor amplifier.
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Type of analysis performed:

"% Choosing Analyses - Cadence® Analog Design Enviro 5[
0K | Can-::ell Defaultsl prlyl Help
Analysis - tran # dc - ac -~ hoise

o Kf - SBNS - dcmatch - - sth

o S - Bnvip - PSS o pac

~- phoise . pxf -~ Psp ~ [pss

= qpac “s gpnoise - qpxr =~ QP3P
DC Analysis

Save DC Operating Point W

Sweep Yariahle
_| Temperature
W Design Variable Variahle Name | V1
I Component Parameter Select Design Variable |
_| Model Parameter

Sweep Range
4 Start-Sto .
g Start |-E¥. Stop |4
. Center- Span
sweep Type

Automatic I

&dd Specific Points  _J

Enabled W Options... I

Figure 52



There are two voltage variables set in this circuit. One is for the VDD voltage and the
other is for Vin source.

% Editing Design Yariables -- Cadence® Ana ﬂ
OK | Cancel| Apply | Apply & Run Simulation Help
selected Varahle Table of Design Variahles
Hame i #  Hame Falue
Value (Expr) |[ 1w 0
2 0w -2

Add | Delete | Change | Mext| Clear| Find

Cellview Variables Copy From | Copy To

Figure 53

The output selected is as highlighted below:

% ¥irtuoso® Schematic Editing: EE330 amplifier schematic — Cad - |0 ﬂ
Cmid: Sel: 0 Status: Selecting outputs\to be plotted... T-27 C Simulator: spectre 3

Tools Design Window Edit Add Check Sheet Options Help

€% [

N
o

0]
T

DI\ % |2 |,

§ |mousE L: mouseSuhSelectPt I: R:
> modify_plot

Figure 54
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This is the waveform obtained form the common-source amplifier.
This waveform plots the output versus the VDD range as Vin is varying from 0->2V.
% Waveform Window 8 -- Cadence® Analog Design Environmen =101 =]
Active 28

Window ZFoom Axes Curves Markers Annotation Edit Tools Help

amplifier schemaotic @ S

mouse L:awvMouseDeleteSelectPtCE () M:

»

This waveform plots the Vin vs VVout as VDD varies.

% Waveform Window 8 -- Cadence® Analog Design Environmen -0 ﬂ
Active 238
Window ZFoom Axes Curves Markers Annotation Edit Tools Help

mouse L:awwMouselDeleteSelectPLCE () M:

=

Figure 55 and 56
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MOS Differential Amplifier with a Current Mirror Load

% ¥irtuoso® Schematic Editing: EE330 differential_amplif i | ﬂ
35

Cmd: Sel: 0 Status: Ready T=27 C Simulator: spectre
Tools Design Window Edit Add Check Sheet Options

DA <8 K

mouse L: mouseSubSelectPt M: R:

=

Help

Figure 57

This is a MOS current mirror load differential amplifier.
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The type of analysis performed is DC.

% Cadence® Analog Design Environment (2) - |I:I|5|

Status: Ready T=27 C Simulator: spectre
session Setup Analyses Varables Outputs Simulation Results Tools

36
Help

Design Analyses

Library EE330

Cell differential amp

Views gchematic

Design Variables Outputs
#  Mame Value #  Name/Signal/Expr ¥alue  Plot Sawe March
1 ¥l 2 1 neti9 ves allwy no
2 w2 -1

= Results in ...todvfsimulationfdifferential_amplifierfspectrefschematic

Figure 58
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The analysis is performed on Variable V2 which is the input voltage.

"% Choosing Analyses - Cadence® Analog Design Envira 5[
0K | Can-::ell Defaultsl prlyl Help
Analysis - tran # dc - ac -~ hoise

o Kf - SBNS - dcmatch - - sth

o S - Bnvip - PSS o pac

~- phoise . pxf -~ Psp ~ [pss

= qpac “s gpnoise - qpxr =~ QP3P
DC Analysis

Save DC Operating Point W

Sweep Yariahle

_| Temperature
W Design Variahle Variable Mame | V2

_| Component Parameter Select Design Variable |
_| Model Parameter

Sweep Range
# Start- Sto . ~
g Start |-li Stop |l
+ Center- Span

sSweep Type

- 3tep Size

_ 10
Linear I # Number of Steps

&dd Specific Points  _J

Enabled W Options... I

Figure 59




The variables used for this simulation are:

% Editing Design Yariables -- Cadence® Analog Design En¥iro El
OK | Cant:ell Apply | Apply & Run Simulation Help
selected Varahle Table of Design Variahles
Hame I- #  Hame Falue
Value {Expr) F 1 v 2
2 Wi =1

Pwldl Deletel Changel Hextl Clearl Fmdl

Cellview Variables Copy Fruml Copy Tul

Figure 60

Where V1 is for the input voltage and V2 is for the VDD voltage source. Check
schematic for more information.

The parametric analysis performed for variable V1 after performing Dc simulation.

% Parametric Analysis - spectre{1): EE330 differential_amplifier schematic - |EI|5|
Tool Setup Analysis Help | 43
Sweep 1 Variable Hame | 71 Add Specification |
Range Type __FomTo | oy E! To |4

Select _|

Step Control L I R Steps

Figure 61
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The waveform obtained looks like below.
This waveform is Vin vs Vout plot.

% Waveform Window 3 -- Cadence® Analog Design E

Window Foom Axes Curves Markers Annotation Edit Tools

EEZZE differentiol_amplifier schemaotic @ Sen

D Re:

mouse L:aweiouseleleteselec M: E:

=

Figure 62

44



High Frequency Response in Diff. Pairs

In order to estimate the frequency response of the differential pair with active current
mirror the schematic model shown below is used where all capacitances are neglected.

X ¥irtuoso® Schematic Editing: EE330 diff_pairs schematic -- Cadence® Analog Desig) =10 ﬂ
Cmd: Sel: 0 Status: Ready T=27 C Simulator: spectre 12

Tools Design Window Edit Add Check Sheet Options Help

2| A% ||

DN\ # T

=

L
N

mouse L: mouseSubSelectPt M: R:

>

DI & b=

Figure 63
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Performing Transient Analysis: The selected nets are input and output nets.

% Cadence® Analog Design Environment (2) - |I:I|5|

Status: Selecting outputs to be plotted... T=27 C Simulator: spectre

session Setup Analyses Varables Outputs Simulation Results Tools

13
Help

Design Analyses
Library EE330 # Type Brouments. ... ... L. Enahle
Cell diff_pairs 1  tran o 25m yes

Views gchematic

Design Variables Outputs
#  Mame Value #  Name/Signal/Expr ¥alue  Plot Sawe March
1 netll ves allwy no
2  net030 yes allv no
3 netlZe yes allv no

= 3elect on Schematic Outputs to Be Plotted

Figure 64

Transient analysis is performed.
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% Choosing Analyses -- Cadence® Ana

0K | Cancel| Defaults| Apply

Analysis # iran dc ac
=f Sens docmatch
sp envip pss
pnoise p=T psp
gpac gpnoise qpxf
Transient Analysis

Stop Time 25m

Accuracy Defaults {ermpreset)
conservative moderate liheral

Enabled W

Help

noise
sth
pac
Opss
qpsp

Options...

The waveforms obtained are: Figure 66

% Waveform Window -- Cadence® Analog Design E

Window Foom Axes Curves Markers Annotation Edit Tools

FEEZZE Aiff_pairs schematic :
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= modify_plot
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Figure 65
-0l x|
Active 15
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Noise in Differential Pairs

¥ ¥irtuoso® Schematic Editing: EE330 noise_Ina schematic -- Cadence® Analog D i | ﬂ
@ik B0 SN (R T=27 C Simulator: spectre 3
Tools Design Window Edit Add cCheck Sheet Options Help

A

mouse L: mouseSubSelectPt M: E:
==| | > modify_plot

Figure 67

This type of modeling accounts for 1/f noise and input-referred noise.
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Performing Transient Analysis: Nets selected are input and output nets.

% Cadence® Analog Design Environmenk {1}

T=27 C Simulator: spectre

Status: Ready

Session Setup Analyses Varables Outputs Simulation Results Tools

=10 %]

a
Help

Design Analyses '—if
. #  Type Broguments. . ... ... Enzble | g
Library EE330 - TRAN
Cell noise lna 1 tran 0 30m yes "
1]
View  schematic vz
Design Variables Outputs [E:
#  Name Value #  Name/Signal/Expc Value Plot Sawe March y
1  netd ves allv no
2  netll ves allv no
= Results in homefatodrifsimulation/noise_Inafspectrefschematic 1{ E
Figure 68
Transient Analysis
¥ Choosing Analyses - Cadence® Analog Design Envira il
0K | Cant:ell Defaultsl prlyl Help
Analysis 4 tran - dc - ac -~ hoise
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Figure 69
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The waveforms obtained;

% Waveform Window 3 -- Cadence® Analog Design E - |EI |ﬂ
®: 13.00m y: -447.3m  /fnet3 Active 11
Window Foom Axes Curves Markers Annotation Edit Tools Help

EEAAE

mouse L:aweiouseleleteselec M: E:

= modify _plot

Figure 70
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