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Starting Encounter for the first time

At first, open a terminal program and source the configuration file cad.init.
> source cad.init
Then create a directory for the project files and change to that directory.

> nkdir cds_encounter _tutorial
> cd cds_encounter_tutorial

Then a script from AustriaMicroSystems is used to initialize the Cadence Custom IC Design tools with
the process technology C35B3 (-t c35b3).

» ans_encounter -t ¢35b3
» encounter
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Fig.1 — Encounter graphical interface.

The Unix shell from which the tool is started is called the Encounter console. The console displays the

“encounter>" prompt. This is where you can enter all Encounter text commands and where the tool
displays messages.

The main window includes three different design views (see Fig.1) that you can toggle during a
session:



0 The Floorplan view, the Amoeba view, and the Physical view. The Floorplan view displays
the hierarchical module and block guides, connection flight lines, and floorplan objects,
including block placement, and power/ground nets.

0 The Amoeba view displays the outline of the modules and sub modules after placement,
showing physical locality of the module.

0 The Physical view displays the detailed placements of the module’s blocks, standard cells,
nets, and interconnects.

In the left bottom of the main window you have a satellite window, which identifies the location of the
current view in the design display area, relative to the entire design. The chip area is identified by a
yellow box; the satellite view is identified by the pink cross box. When you display an entire chip in
the design display area, the satellite cross box encompasses the chip area yellow box. When you zoom
and pan through the chip in the design display area, the satellite cross box identifies where you are
relative to the entire chip.

» To move to an area in the design display area, click and drag on the satellite cross box.

* To select a new area in the design display area, click and drag on the satellite cross box.

* To resize an area in the satellite window, click with the Shift key and drag a corner of the cross box.
* To define a chip area in the satellite window, right-click and drag on an area.

Starting Encounter again

If you want to start a new Encounter session in a directory where the Cadence tool has already been
initialized, only the following commands are necessary:

> source cad.init
> cd cds_encounter_tutorial
> encount er

Design import

Importing the design into Encounter involves specifying the following setup information:

« Design libraries and files. This includes information on the technological process and the cell library
in the LEF (Layout Exchange Format) format. LEF files provide information such as metal and via
layers and via generate rules which are used for routing tasks. They also provide the minimum
information on cell layouts for placement and routing.

 Gate-level netlist. This relates to the (Verilog) netlist to be placed and routed.

« Timing libraries. This includes information on the cell timings (delays, setup/hold times, etc.).
 Power information. This relates to the power nets to use in the layout.
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Fig.2 — Import design dialogue box.

To start the design import, select Design -> Design Import... in the main menu. Then, click on the
Load... button and load the file c35b3_std.conf. This file defines a basic import configuration. There
are a number of additions and changes required to the initial configuration. The new configuration will
then be saved for future uses.

The first information to add is the netlist. Click on the ... button on the right of the Verilog Files field.
You get a new dialog window with only one pane. Click on the top-right icon to get the full window.
Remove the VERILOG/none line in the left pane. Select the Verilog netlist file ../b03.v, add it to the
left pane and close the window.

In the Design Import window, select the Auto Assign box to let the tool extract the top cell name from
the file. If the Verilog file includes more than one design (more than one top module name), you need
to give the name of the top module to use explicitly.
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Fig.3 — Netlist files dialogue box.

In the “LEF files” and “Common Timing Libraries” fields, you should remove the reference to the 10
pad library since you will not include pads in this design. Remove the paths:
/soft/ams/v3.7/artist/HK C35/LEF/ c35b3/1COLIB_4M | ef
/soft/ams/v3.7/liberty/c35 3.3V/c35 IQLIB 4MIib

In the Power tag, you can keep only the vdd! and gnd! power nets if you won’t add periphery cells.
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Fig.4 — Design import: power dialogue box.
In the Timing tag, you can specify the timing constraints that you used for synthesis.
Select the file ../b03.sdc  (in the Synopsys Design Constraints format):
set sdc_version 1.6
set _operating_conditions WORST-IND -1ibrary ¢35 CORELIB

set _max_area O
create_clock -nane clock -period 10 -waveform{0 5}
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Fig.5 — Design import: timing dialogue box.

Not all the constraints in the file are actually supported in Encounter. In our case, only the clock
definition is actually imported.

The rest of the settings can be left as is. You can now save the updated configuration in the file
./b03.conf by clicking on the Save... button.

Finally, click on OK. The configuration is then read in.

In the case of the AMS design kit, a number of similar errors are reported when the LEF file is loaded.
The error message is like:

*ERROR: Macro '...' obs coordinate y value... isn't on manufacturing
grid.
It's likely result in placenent/routing that can't be manufactured

The errors can be safely ignored. The violating coordinates belong to obstructions in the cell LEF file
that describe 45 degree shapes. These shapes are not on the manufacturing grid, but this is no problem
for the place & route flow. Finally the cells are replaced by the complete layouts anyhow.

To reload a configuration, select Design -> Design Import... in the main menu. Then, click on the
Load... button and load the configuration file ./b03.conf.



The grid should be defined as a multiple of 1.4 micron.
Select Design -> Preferences... in the main menu and in the Floorplan tag check the User-defined

Grid followed by the Snap All Corners to Grid option. Define the two boxes of the User-defined Grid
as 1.4 micron (as showed in figure 6).

Click on Apply and OK.
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Fig.6 — Preferences dialogue box.

Global net connections

This step assigns pins or nets to global power and ground nets.
Select Floorplan -> Global Net Connections... in the main menu.
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Fig.7 — Global net connections.

The left pane (Connection List) is initially empty. For each VDD and ground net:

* Check the Pins field and enter the pin name (vdd! or gnd!).

« Fill the To Global Net field with either vdd! or gnd!.

« Click on Add to List. The left pane now includes the related global net connection.
Click on Apply and Close.

Operating conditions definition

The operating conditions define the temperature, process and voltage conditions for the design. They
impact the timing calculations and optimizations.

Select the Timing -> Specify Analysis Conditions -> Specify Operating Condition/PVT... in the
main menu.
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Fig.8

In the max tab, select the WORST-IND operating condition. In the min tab, select the BEST-IND
operating condition.



Click OK.

The max operating conditions will be used to meet setup timing constraints, while the min operating
conditions will be used to meet hold timing constraints.

Floorplan Specification

The floorplan defines the actual form, or aspect ratio, the layout will take, the global and detailed
routing grids, the rows to host the core cells and the 1/O pad cells (if required), and the location of the

corner cells (if required).

Select Floorplan -> Specify Floorplan... in the main menu.
Specily Fleoirplan — 4
Design Dimensions
Speciy Dimenslons by
. Sioe by
<+ Core Size y: .- Aspact Hatin 082307682
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. Die Sire by:  Width and Hesght 154.0
163.8
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Define the core width and height with the values showed in figure 9 (check the Width and Height box).

Alternatively the core size can be defined as an aspect ratio of 1.

Setting the core utilization to 85%, means that 15% of the core area will be free for possible future
buffer insertions or cell replacements. The other utilization ratio (Std. Utilization) refers to the density
of the standard cells.

Define 1/O to core distances of 18.2 micron. This is enough since there won’t be any periphery cells
(/O pads) in the layout. The cell rows will be abutted and flipped each two row to share VDD and
ground power rails.

Click OK.

The display design area pane now shows the defined floorplan with the required number of rows.

It is a good idea to save the design at that stage to allow restarting here quickly without needing to redo
all the previous steps. Select Design -> Save Design... in the main menu and save the current state in

the file cds_encouter_tutorial/b03.enc. The data is actually saved in the directory
cds_encounter_tutorial/b03.enc.dat.

To restore design data, select Design -> Restore Design... in the main menu and select the .enc file
to read in the cds_encounter_tutorial directory.

Fig.10

CAP cell placement

The AMS design kit requires that physical-only termination cells must be placed at each row ends. The
so called CAP cells are used to properly bias the P+ and N+ substrates.

Select Place -> Filler -> Add End Cap... in the main menu. Then, select the ENDACPL cell as the
cell to place at the beginning of each row and the ENDCAPR cell as the cell to place at the end of each
row.

Click OK. The added cells are now visible in the Physical view (type <f> to redraw and fit the design
in the window).

11
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Power ring/stripe creation and routing

This step generates the VDD and ground power rings around the core and optionally adds a number of
vertical and/or horizontal power stripes across the core. Stripes ensure a proper power distribution in
large cores.

Select Floorplan -> Power Planning -> Add Rings... in the main menu.
The Net(s) field defines the number and the kinds of rings from the core. In our case, there will be first

a ground ring around the core and a VDD ring around the ground ring. The net names should be
consistent with the power net names in the cell LEF file.

12
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Fig.12

The ring configuration defines ring widths of 4.2 micron spaced by 0.7 micron. The rings will be
placed in the centre of the channel between the core and the chip boundary (or the 10 pads, if any).

It is possible to extend the ring segments to reach the core boundary. Click on the Advanced tab and
click on the segments you’d like to extend (see Fig.13). Other power and ground side trunks can be
defined by selecting only horizontal or vertical segments.

Click OK to generate the rings.

13



Fig.13

To add power stripes, select Floorplan -> Power Planning -> Add Stripes... in the main menu.
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Fig.15

The Net(s) field defines the pattern. Here a single pattern will be generated (select Number of sets and
insert 1). Each stripe will be 2.8 micron wide and the space between them will be 1.4 micron.

Check Relative from core or selected area and enter the value 63 (micron) in the X from left field.
The two stripes will be vertically placed near the centre of the core. It is possible to measure sizes by

using the ruler (press ESC to remove all rulers).

Click on the Advanced tab and on the Maximum length of same layer jog insert 1.4. On bottom of the

dialogue box, on Snap wire center to routing grid, select Grid.

Click on Apply and OK to generate the stripes.

Now, it is possible to route the power grid. Select Route -> SRoute... in the main menu. All default

values are fine. Click OK to do the routing. The design now looks like below:
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Fig.16

It is recommended to save the new stage of the design. Select Design -> Save Design... in the main
menu and save the current state in the file cds_encounter_tutorial/b03.enc.

Core cell placement

This steps places the cells of the imported Verilog netlist in the rows.

Select Place -> Place... in the main menu.

r}( Place _ x
Flacement Effort Level '
Prototyping
Lows Effort
Medium Effort
High Effort

Timing Oriven
| Save Mew Metlistto h03.post_tdp.w '_

lgnore Scan Connection
lgnore Spare Cell Connection

Save Placement to |b03.place |
[0] 4 Cancel Help
Fig.17
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Select the Timing Driven option. This is only valid if timing constraints have been properly defined on
the design. This option will optimize the placement of the cells that are on the critical path.

Click OK to do the placement. It may take some time to complete, especially when the placement is
timing driven.

Clock tree synthesis (optional)

As the paths that will propagate the clock signal in the design are not necessarily balanced, some
registers may receive the active clock edge later than others (clock skew) and may therefore violate the
assumed synchronous design operation. For example, the original clock tree we can get from the
previously placed design is:

# FirstEncounter(TM C ock Synthesis Technol ogy File Format
# for automatic gated clock tree synthesis
Aut oCTSRoot Pi n <cl ock root pin nanme>
MaxDel ay <nunber >

M nDel ay <nunber >

Si nkMaxTr an <numnber >

Buf MaxTr an <nunber >

Max Skew <numnber >

NoGat i ng <rising|falling| NO
MaxDept h <nunber >

Buf f er <cell 1> <cell 2> <cell 3> ....
Leaf Pi n

+ <pin nane> <rising|falling>

+ ...

Leaf Port

+ <port nanme> <rising|falling>

+ ..

Excl udedPi n

+ <pin nanme>

+ ...

Excl udedPort

+ <port nane>

+ ..

End

HFHHFEHFFEHFEHFEHEFEHHFEHEHEFEHFEHHFHR

Aut oCTSRoot Pi n cl ock

NoGat i ng rising
MaxDel ay 3ns

M nDel ay Ons

Max Skew 150ps

Si nkMaxTr an 400ps

Buf MaxTr an 400ps

Buf f er BUF2 | NVO
End

You will see the following data in the b03.cts.auto file:

0 The clock root name is clock.
0 The max and min insertion delays are specified as 3 and O ns.
0 The transition on clock nets is specified as 400 ps, while the clock skew is 150 ps.

The NoGating option instructs the clock tree generation tool to stop at nonbuffer/noninverter pins and

to use the specified edge as the trigger edge.
If you have more internal clocks, add their information to the specification file.

17



In order to load the clock tree specification file select Clock -> Specify Clock Tree... in the main

menu and select the file ../b03.cts.auto that has been previously created.

X Specify Clock Tree E| [E|
Specification Selection
’TSIDGKTree File: |./b03.cts.auto El
ok | apply | cancet | Hep
Fig.18

To create the clock tree, select Clock -> Synthesize Clock Tree ... in the main menu.
Define the result directory as b03_cts and the base file name as b03_cts.
Click OK to create the clock tree.

X Synthesize Clock Tree [:_] @

Clock Tree Synthesis
[T Set Added Clock Buffers as Fixed

I Handle Clock Crossover and Eeconvergence

—Clock Tree Results
[~ Sawve Metlist

[~ Save Placement
[~ Zave Clock Tree Synthesis Report
[~ Save Clock Tree Fouting Guide
| Save Clock Tree hMacro Model
I~ Save Clock Mets
Result Directory:  |b03_cts
Base File Name:  |b03_cts

oK aply | cancel Help

Fig.19

Now it is possible to run timing optimization, based on the generated clock tree. Select Timing ->

Optimization... in the main menu and check postCTS. Click OK to do the optimization.

18
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Fig.20

The console will display the results of the timing optimization:

Set up node
Worst Slack: 0.000ns
TNS: 0.000ns Violating Paths: 0
Pat hgr oup Sl acks
reg2reg: 0.000ns
i n2reg: 0.000ns
reg2out: 0.000ns
i n2out : 0. 000ns
Density: 96.954%
Routing Overflow. 0.00%H and 2.39% V
Real DRV (fanout, cap, tran): (0, 0, 0)
Total DRV (fanout, cap, tran): (0, 0, 0)
**optDesign ... cpu = 0:0:0, real = 0:0:1, nem= 97.6M **
*** Fini shed optDesign ***

Design routing

This step generates all the wires required to connect the cells according to the imported gate-level
netlist.

To route the design, select Route -> Nanoroute... in the main menu and check the Insert Diodes box.

On the Diode Cell Name insert FILLANTZ, FILLANT2, FILLANT5 and FILLANT10.
Click OK to do the routing.
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Fig.21 — Nanoroute dialogue box.

Filler cells

Filler cells will fill remaining holes in the rows and ensure the continuity of power/ground rails and

N+/P+ wells in the row.

To fill the holes with filler cells, select Place -> Filler -> Add Filler... in the main menu. Select the
cells FILL1, FILL2, FILL5, FILL10, FILL25 and FILLRT1, FILLRT2, FILLRT5, FILLRT10,
FILLRT25 and click OK to place the filler cells.

Do not add filler cells now if you intend to synthesize a clock tree. Clock tree synthesis may need some
free space to insert clock buffers to balance the clock paths.

Kb Filbe=

Cell Mame(s) FILLET1 FILLRTZ FILLA®  Salect
Pref: [FILLER
™ Fil Boundary
1 Fill Aresy  Drove

I | Iy |

LK | ury |

ok | Conced | el |
Fig.22

The placement should then look like below (redraw <f> the image if it was not updated):
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Fig.23

Timing analysis

Select Timing -> Timing Analysis... in the main menu. Define the path for the slack report file.
Click OK.
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Fig.24

Help

—

In the console window you get a summary of the timing analysis and the slack report file includes more

detailed information.

Right after the placement it is also possible to get a first report on the design timing with the same

procedure.

Design checks

The Verify menu has a number of items to check that the design has been properly placed and routed.

Select Verify -> Verify Connectivity... in the main menu.
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Fig. 25

Define the report file as ./RPT/b03.conn.rpt. Click OK. The console displays the results. Confirm that

there are no violations or warnings.

Select Verify -> Verify Geometry... in the main menu.
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In the Advanced tab, define the report file as b03.rpt. Click OK. The console displays the results.

Report generation

A number of reports have been already generated in the previous steps. They should be located in the
working directory. The Tools menu includes some additional reports, try:

Tools -> Netlist Stats...

Tools -> Gate Count Report...

Tools -> Summary Report...

in order to obtain different types of statistical information.

Post-route timing data extraction

This step generates the post-route SDF (Standard Delay Format) file that includes both the actual
interconnect and cell timing delays.

The parasitics must be first extracted. Select Timing -> Extract RC... in the main menu.

The generated cap file includes the wired capacitance, pin capacitance, total capacitance, net length,
wire cap per unit length and the fanout of each net in the design.

The generated SPEF (Standard Parasitics Exchange Format) file includes RC values in a SPICE-like
format.
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The SDF file may be then generated by selecting Timing -> Calculate Delay... in the main menu.

The checked Ideal Clock switch means that flip-flops are considered as having Ops rising and falling
transition times.

Post-route netlist generation

This step generates a Verilog netlist of the routed design. The netlist may be different from the
imported netlist as cells may have been added or replaced during clock tree synthesis and timing-driven
optimizations.

Select Design -> Save -> Netlist... in the main menu.

The generated file should be saved into the HDL/GATE directory.

% save Netlist =) [

I Include Intermediate Cell Definition
[T Include Leaf Cell Definition
Metlist File: %EDS_muted.u

oK Cancel Help |

Fig.27

GDS2 file generation

The placed and routed design can be exported in different formats for further processing outside the
Encounter tool. The GDS2 binary format is a standard format for integrating the block in the top-level
layout, doing DRC/LVS checking, or delivering the layout to the foundry.

To export the design in the GDS2 format, select Design -> Save -> GDS... in the main menu.

The GDS map file has been copied by the AMS setup script in the DEX directory. The generated GDS2
file is written in the same directory.
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Fig.28

Design import in Virtuoso

The GDS2 file can be imported in Virtuoso for further processing. To do that, it is recommended to
start the Cadence IC environment in the LAY directory.

Start Cadence IC:

ams_cds -t ¢35b3 -mfb

Create a new library called b03 with the attached technology file TECH_C35B3.

In the DFII shell, select File -> Import -> Stream....
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Fig.30

In the Options tab, check the Retain Reference Library (No Merge) option. Since the cell layouts are
available in the CORELIB library, it is possible to display the full layout of the block.
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Fig.31 — b03 layout (in Virtuoso console).

Using scripts (optional)

It is much more convenient to capture the placement and routing flow in a script. Cadence Encounter
also supports the Tcl language for building scripts.

An example of such a script for placement and routing is presented next.
To run a Tcl script, execute the following command in a Unix shell:
>encounter script_nane.tcl

The example given below may be modified to define design information and to control the flow to
some extent.

Cadence Encounter Tcl script for adder-subtractor.

Process: AMS 0.35u CMOS (C35), Hit-Kit 3.70

It is assumed that a project directory structure has already been
created using 'create_project' and that this synthesis script is
executed fromthe project root directory $PRQJECT_DI R

set PRQIECT_DI R [ pwd]

HHHFHFHFHHFHHHR

set DESI GN addsub_nbits8
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set TIM LIBRARY C35_CORELIB

set TIM OC MAX WORST ;# TYPI CAL | WORST | WORST-1ND
set TTIM OC M N BEST ;# TYPICAL | BEST | BEST-IND
# Fl oorpl an settings

#

set FP_ASPECT RATIO 1

set FP_ROWDENSITY 0.85 ;# percent

set FP_CORE21 O 16 ;# mcron

# Power ring and settings

#

set PR WDTH 4 ;# micron

set PR SPACING 1 ;# micron

set PR _LAYER TB MET1 ;# top and bottom | ayer
set PR LAYER LR MET2 ;# left and right |ayer
# Power stripe settings

#

set ST_NUM SETS 1 ; # nunber of sets

set ST_SPACING 1 ;# micron

set ST_LAYER V $PR_LAYER LR

set ST WDTH 2 ;# micron

set ST _XOFS R 60 ;# micron

set ST_XOFS L 60 ;# micron

# Pl acenent settings

#

set PL_EFFORT -high ;# -low | -medium| -high
# Cock tree synthesis settings

#

set CTS_BUFFER BUF2

set CTS_INV I NVO

Fl ags that drive the script behavior (can be changed)

ADD STRIPES (0 | 1)

if 1, add stripes

PLACE_ TIMNG (0 | 1)

if 1, do a timng driven placenent

CLOCK_TREE (0 | 1)

if 1, create a clock tree

CTS_CREATE_SPEC (0 | 1)

if 1, create a clock tree specification file with default val ues
ROUTE_TIM NG (0 | 1)

if 1, do a timng driven routing

OPT (string)

can be used to have different generated file nanes

HHEHHFHFHHFHFHFHHFEHFHFFHH

set ADD STRIPES 1

set PLACE_TIM NG 1
set CLOCK_TREE 1

set CTS_CREATE_SPEC 0
set ROUTE_TIM NG 1
set OPT "_cts"

set CONF_FI LE_NAMVE ${DESI G\}. conf

set DESI GN_NAME ${ DESI G\} ${ OPT}

set SAVE_DESI GN_FP_NAME ${ DESI GN_NAME} - f pl an. enc
set SAVE DESI GN_PR _NAME ${ DESI GN_NAME} - pri ng. enc
set SAVE_DESI GN_PL_NAME ${ DESI GN_NAME} - pl aced. enc
set SAVE_DESI GN_PF_NAME ${ DESI GN_NAME} - pl aced_fill ed. enc
set SAVE_DESI GN_CT_NAME ${DESI GN_NAME} - ct s. enc
set SAVE DESI GN_RO NAME ${ DESI GN_NAME} - r out ed. enc
set TI M _RCDB_NAME ${ DESI GN_NAME} . r cdb

set SDF_FI LE_NAME ${ DESI GN_NAMNE} - r out ed. sdf

set SPEF_FI LE_NAME ${ DESI GN_NAME} - r out ed. spef

set RPT_CHECK _TA NAME ${ DESI GN_NAME} - checkt a. r pt
set RPT_REPORT_TA NAME ${ DESI GN_NAME} -t a. rpt

set RPT_SLACK NAME ${ DESI GN_NAME} - sl ack. r pt
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set RPT_GATE_COUNT_NAME ${DESI GN_NAME} - gat e_count . r pt
set RPT_NOTCH _NAME ${ DESI GN_NAME} - not ch. r pt

set RPT_CONN_NAME ${ DESI GN_NAME} - conn. r pt

set RPT_GEOM NAME ${ DESI GN_NAME} - geom r pt

set RPT_DENSI TY_NAME ${DESI GN_NAME} - density. rpt

set VLOG NETLI ST_SI M NAME ${ DESI GN_NAME} - r out ed. v

set VLOG NETLI ST_LVS NAME ${ DESI GN_NAME} -rout ed_| vs. v
set CTS_SPEC NAME ${DESI GN_NAME} - spec. cts

set CTS_RGU DE_NAME ${ DESI GN_NAME} - gui de. ct's

set CTS RPT_NAME ${DESI GN_NAME}-cts. rpt

set GDS_FI LE_NAME ${ DESI GN_NAME} . gds

set CONF_FI LE ${PRQJECT DI R}/ PAR/ CONF/ ${ CONF_FI LE_NAVE}

set SAVE_DESI GN_FP_FI LE ${PRQIECT DI R}/ PAR/ DB/ ${ SAVE_DESI GN_FP_NAME}
set SAVE_DESI GN_PR_FI LE ${PRQJECT DI R}/ PAR/ DB/ ${ SAVE_DESI GN_PR_NANE}
set SAVE_DESI GN_PL_FI LE ${PRQJECT DI R}/ PAR/ DB/ ${ SAVE_DESI GN_PL_NAME}
set SAVE_DESI GN_PF_FI LE ${PRQJECT DI R}/ PAR/ DB/ ${ SAVE_DESI GN_PF_NANE}
set SAVE_DESI GN_CT_FI LE ${ PRQJECT DI R}/ PAR/ DB/ ${ SAVE_DESI GN_CT_NAME}
set SAVE_DESI GN_RO FI LE ${PRQJECT DI R}/ PAR/ DB/ ${ SAVE_DESI GN_RO_NAME}
set SDF_FILE ${PRQJECT DI Rt/ PAR/ TI M ${ SDF_FI LE_NANME}

set SPEF_FI LE ${PRQIECT DI R}/ PAR/ TI M ${ SPEF_FI LE_NAVE}

set TIM RCDB_FI LE ${ PROJECT DI R}/ PAR/ TI M ${ TI M_RCDB_NAVE}

set RPT_CHECK TA FI LE ${ PRQJECT DI R}/ PAR/ RPT/ ${ RPT_CHECK_TA_NANE}

set RPT_REPORT_TA FI LE ${PRQJECT DI R/ PAR/ RPT/ ${ RPT_REPORT_TA NAVE}
set RPT_SLACK FI LE ${ PROJECT DI R}/ PAR/ RPT/ ${ RPT_SLACK_NAVNE}

set RPT_GATE _COUNT_FI LE ${ PRQJECT DI R}/ PAR/ RPT/ ${ RPT_GATE_COUNT _NAVNE}
set RPT_NOTCH_FI LE ${ PROJECT DI R}/ PAR/ RPT/ ${ RPT_NOTCH_NANE}

set RPT_CONN_FI LE ${ PROJECT DI R}/ PAR/ RPT/ ${ RPT_CONN_NANE}

set RPT_GEOM FI LE ${ PROJECT DI R}/ PAR/ RPT/ ${ RPT_GEOM NAVE}

set RPT_DENSI TY_FI LE ${ PROJECT_DI R}/ PAR/ RPT/ ${ RPT_DENSI TY_NANE}

set VLOG NETLI ST_SI M FI LE ${PRQJECT DI R}/ HDL/ GATE/ ${ VLOG_NETLI ST_SI M_NANE}
set VLOG NETLI ST_LVS FI LE ${PRQIECT DI R}/ HDL/ GATE/ ${ VLOG NETLI ST_LVS_NANE}
set CTS_SPEC FI LE ${ PROJECT DI R}/ PAR/ CTS/ ${ CTS_SPEC_NAVE}

set CTS_RGU DE_FI LE ${ PROJECT DI R}/ PAR/ CTS/ ${ CTS_RGUI DE_NANE}

set CTS_RPT_FILE ${PROJECT DI R}/ PAR/ RPT/ ${ CTS_RPT_NANE}

set GDS_FILE ${PRQJECT DI R/ PAR/ DEX/ ${ GDS_FI LE_NANE}

set GDS_MAP_FI LE ${PROJECT DI R}/ PAR/ DEX/ gds2. map

# make_cl ock_tree

#

proc nmake_clock _tree create_spec {

gl obal CTS _BUFFER CTS | NV CTS_SPEC FI LE CTS_RGUI DE_FI LE CTS_RPT_FI LE
if { $create_spec || ![file exists $CTS SPEC FILE] } {

creat eC ockTreeSpec \

- buf Foot print $CTS_BUFFER \

-invFootprint $CTS_INV \

-out put $CTS_SPEC FI LE

}

speci fyd ockTree -cl kfile $CTS_SPEC FI LE
ckSynt hesi s \

-rgui de $CTS_RGUI DE_FI LE \

-report $CTS RPT_FILE

opt Desi gn -postCTS -setup -drv -outDir PAR/ RPT
} ;# make_cl ock_tree

| oadConfig $CONF_FILE O
comi t Config

set OpCond \
-maxLi brary $TI M LI BRARY -max $TI M OC _MAX \
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-minLibrary $TIMLIBRARY -nin $TIM OC M N
# Set user grids

set Preference ConstraintUserXGid 0.1
set Preference Constrai ntUser XOfset 0.1
set Preference ConstraintUserYGid 0.1
set Preference Constrai ntUser YO fset 0.1
set Preference SnapAll Corners 1

set Preference Bl ockSnapRule 2

# Define gl obal Power nets - nmke gl obal connections

cl ear d obal Nets

gl obal Net Connect vdd! -type pgpin -pin vdd! -inst * -nmodule {} -verbose

gl obal Net Connect gnd! -type pgpin -pin gnd! -inst * -nmodule {} -verbose

#gl obal Net Connect vdd3o! -type pgpin -pin vdd3o! -inst * -nodule {} -verbose
#gl obal Net Connect vdd3r1! -type pgpin -pin vdd3rl! -inst * -nodule {} -verbose
#gl obal Net Connect vdd3r2! -type pgpin -pin vdd3r2! -inst * -nodule {} -verbose
#gl obal Net Connect gnd3o! -type pgpin -pin gnd3o! -inst * -nodule {} -verbose
#gl obal Net Connect gnd3r! -type pgpin -pin gnd3r! -inst * -nodule {} -verbose

floorPlan -r $FP_ASPECT_RATI O\

$FP_ROW DENSI TY \

$FP_CORE2] O $FP_CORE2I O $FP_CORE2] O $FP_CORE2I O
fit

saveDesi gn $SAVE_DESI GN_FP_FI LE

addRi ng \

-around core \

-nets { gnd! vdd! } \

-wi dt h_bottom $PR_W DTH -wi dt h_top $PR_W DTH \
-width_|left $PR WDTH -w dt h_ri ght $PR_W DTH \

- spaci ng_bott om $PR_SPACI NG - spaci ng_t op $PR_SPACI NG \
-spacing_l eft $PR_SPACI NG - spaci ng_ri ght $PR_SPACI NG \
-l ayer_bottom $PR _LAYER TB -l ayer _top $PR LAYER TB \
-layer _|left $PR LAYER LR -layer_right $PR _LAYER LR\
-center 1\

-t 1 -tr 2 -bl 12 -br 1 -1t 1 -Ib1-rt 1 -rb 1\
-stacked_via_bottom | ayer MET1 -stacked_via_top_| ayer MET4 \
-threshold 0.7

if { $ADD STRIPES } {

addstri pe \

-nets { gnd! vdd! } \

-nunber _of _sets $ST_NUM SETS \

-spaci ng $ST_SPACI NG \

-layer $ST_LAYER V \

-width $ST_WDTH \

-xl eft_offset $ST_XOFS_ L

sroute \

-jogControl { preferWthChanges differentLayer } \
-nets { gnd! vdd! }

saveDesi gn $SAVE_DESI GN_PR FI LE

# Core cell placenent
if { $PLACE_ TIMNG } {

anpebaPl ace $PL_EFFORT -tim ngdriven
} else {
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anoebaPl ace $PL_EFFORT

}
set Dr awvbde pl ace
saveDesi gn $SAVE _DESI GN _PL_FI LE

if { $CLOCK_TREE } {
make_cl ock_tree $CTS_CREATE_SPEC
saveDesi gn $SAVE_DESI GN_CT_FI LE

addFiller -cell FILL25 FILL10 FILL5 FILL2 FILLY1 -prefix FILLER

saveDesi gn $SAVE_DESI GN_PF_FI LE

if { SROUTE_TIMNG } {

set NanoRout eMbde - qui et -timnm ngEngine CTE

set NanoRout eMbde -qui et -routeWthTim ngDriven true
set NanoRout eMbde -quiet -routeTdrEffort O

}

gl obal Det ai | Rout e

opt Desi gn -postRoute -setup -drv -outDir PAR/ RPT
saveDesi gn $SAVE_DESI GN_RO FI LE

set Drawvbde pl ace

fillNotch -report $RPT_NOTCH FI LE
veri fyConnectivity \

-type all \

-error 1000 \

-war ni ng 50 \

-report $RPT_CONN_FI LE
verifyGeonetry \

-al |l owSaneCel | Viol s \

-al | owRout i ngBl kgPi nOverl ap \
-al | owRout i ngCel | Bl kgOverl ap \
-report $RPT_GEOM FI LE
verifyMetal Density \

-detailed \

-report $RPT_DENSI TY_FI LE

# Extract parasitics

set Ext ract RCvbde \
-detail \

-rcdb $TI M RCDB_FI LE \
-relative_c t 0.01\
-total _c_t 5.0\
-reduce 5

extract RC

rcQut -spef $SPEF_FILE
del ayCal -sdf $SDF_FILE

report Gat eCount -outfile $RPT_GATE_COUNT_FI LE
# Tim ngs

#

set Ct eReport

set Anal ysi sMbde -setup -async -skew -noCl ockTree -sequenti al Const Prop
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report Anal ysi sMbde

bui | dTi M ngG aph

checkTA -verbose > $RPT_CHECK TA FI LE

report TA \

-format { hpin arc cell delay arrival required slew fanout load } \
-late \

-max_points 10 \

-net \

> $RPT_REPORT_TA FI LE

Ho o m o e e o e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e
# Save netli st

Ho o m o e e o e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e e

saveNet | i st -excludeLeaf Cel | $VLOG NETLI ST_SI M FI LE
saveNet | i st -physical $VLOG NETLIST_LVS FI LE

streamOut $GDS_FI LE \

-mapFi |l e $GDS_MAP_FI LE \

-1 i bNane ADDSUB \
-structureNanme $DESI GN_NAME \
-stripes $ST_NUM SETS \
-units 1000 \

-nmode ALL
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