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Starting Encounter for the first time

At first, open a terminal program and source the configuration file cad.init.
> source cad.init
Then create a directory for the project files and change to that directory.

> mkdir cds_ encounter tutorial
> cd cds_encounter tutorial

Then a script from AustriaMicroSystems is used to initialize the Cadence Custom IC Design tools with
the process technology C35B3 (-t ¢35b3).

» ams_encounter -t c35b3
» encounter

Cncounbes - fhomeeSededp D0 be ct /800G 10

Design  Cot  [epchlp  Meclitos Moo Mace  Gaock Roite  Thming 31 ower vediy Tools  Help |

EREEEPERE FRREREEREE TR

s — [ o |
.
i I [ a1
I =
dodve I
CeoDce Wl T
RE et W r
e |
Dbsluc, WO T
Tecon | o
oreer | T
Instancz 0 [
et B
_ _ sl ==
Display design area - wrr
Tule- =
Floorplan view wiorgest
HCcwest [l
W ol [ s
] %[Amoeba view |
4 |
Physical view ’

o i 207, -3

Fig. 1 Ecounter graphical interface.

The Unix shell from which the tool is started is called the Encounter console. The console displays the
“encounter>" prompt. This is where you can enter all Encounter text commands and where the tool
displays messages.

The main window includes three different design views (see Fig. 1) that you can toggle during a
session:



o The Floorplan view, the Amoeba view, and the Physical view. The Floorplan view displays
the hierarchical module and block guides, connection flight lines, and floorplan objects,
including block placement, and power/ground nets.

o The Amoeba view displays the outline of the modules and submodules after placement,
showing physical locality of the module.

o The Physical view displays the detailed placements of the module’s blocks, standard cells,
nets, and interconnects.

In the left bottom of the main window you have a satellite window, which identifies the location of the
current view in the design display area, relative to the entire design. The chip area is identified by a
yellow box, the satellite view is identified by the pink crossbox. When you display an entire chip in the
design display area, the satellite crossbox encompasses the chip area yellow box. When you zoom and
pan through the chip in the design display area, the satellite crossbox identifies where you are relative
to the entire chip.

* To move to an area in the design display area, click and drag on the satellite crossbox.

* To select a new area in the design display area, click and drag on the satellite crossbox.

* To resize an area in the satellite window, click with the Shift key and drag a corner of the crossbox.
* To define a chip area in the satellite window, right-click and drag on an area.

Starting Encounter again

If you want to start a new Encounter session in a directory where the Cadence tool have already been
initialized, only the following commands are necessary:

> source cad.init
> cd cds_encounter tutorial
> encounter

Design import

Importing the design into Encounter involves specifying the following setup information:

* Design libraries and files. This includes information on the technological process and the cell library
in the LEF (Layout Exchange Format) format. LEF files provides information such as metal and via
layers and via generate rules which is used for routing tasks. They also provide the minimum
information on cell layouts for placement and routing.

* Gate-level netlist. This relates to the (Verilog) netlist to be placed and routed.

 Timing libraries. This includes information on the cell timings (delays, setup/hold times, etc.).

* Power information. This relates to the power nets to use in the layout.



X Design Import E] E]

Werilog Files:|./b03.u =
LM Files:| _|

Top Cell: # Auto Assign - By User: \none

Design | Core Sni

— Metlist;

— Technology Information/Physical Libraries:
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Abstract View Names: |
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— Timing Libraries:
Mex Timing Libraries: |

Min Timing Libraries: |
Common Timing Libraries: IfSDWameS.?ﬂibEWf035_3.3VfCSE_COREL|B.Hb
Stamp Model Definitions: |
Stamp Model Data: |
Buffer NamefFootprint:|BUF2 BUF4 BUFE BUFS BUF 12 BUF15
Delay NamefFootprint:|DL\r’12 DLYZz DLY3z DLY 42
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Fig. 2 Import design dialogue box.

To start the design import, select Design -> Design Import... in the main menu. Then, click on the
Load... button and load the file c35b3_std.conf. This file defines a basic import configuration. There
are a number of additions and changes required to the initial configuration. The new configuration will
then be saved for future uses.

The first information to add is the netlist. Click on the ... button on the right of the Verilog Files field.
You get a new dialog window with only one pane. Click on the top-right icon to get the full window.
Remove the VERILOG/none line in the left pane. Select the Verilog netlist file ../b03.v, add it to the
left pane and close the window.

In the Design Import window, select the Auto Assign box to let the tool extract the top cell name from
the file. If the Verilog file includes more than one design (more than one top module name), you need
to give the name of the top module to use explicitly.
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Fig. 3 Netlist files dialogue box.

In the “LEF files” and “Common Timing Libraries” fields, you should remove the reference to the 10
pad library since you will not include pads in this design. Remove the paths:
/soft/ams/v3.7/artist/HK C35/LEF/c35b3/IOLIB 4M.lef
/soft/ams/v3.7/liberty/c35 3.3V/c35 IOLIB 4M.lib

In the Power tag, you can keep only the vdd! and gnd! power nets if you won’t add periphery cells.

Design Impornt M=l

Design | Core Spec Defaults | Timing | Power | Misc. |

— Power/Ground Mets:
Power Nets:|udd!

Ground Mets:}gnd|

— Power Analysis Scaling

Toggle Rate Scale Factor: | 1.0

Fig. 4 Design import - power dialogue box.
In the Timing tag, you can specify the timing constraints that you used for synthesis.
Select the file ../b03.sdc (in the Synopsys Design Constraints format):
set sdc _version 1.6
set operating conditions WORST-IND -library ¢35 CORELIB

set_max_area 0
create clock -name clock -period 10 -waveform {0 5}




Design Import

— Delay Calculation Defaults
Exclude Net File: |

Cefault Delay Pin Limit:l 1000
Default Net Delay:l 1000.0ps

Default Met Load: 0.5pf

Input Transition Delay:l 0.1ps

— RC Extraction

Capacitance Tahle File:|fsofu’amSIS.?.fartistn’HK_C35fLEFIencounterchEbS.capTable
[Default Cap. Scale Factor:l—m
Detail Cap. Scale Factor:I—m
Coupling Cap. Scale Factor:l—m
Fesistance Scale Factor:l—m
Shrink. Factor:|—1.D
Relative C Threshold (0-0.2):] 001
Total C Threshold (F)(0-20%[ 50

— Timing Constraint Information
Timing Constraint File:|..a’bDS.sdc

Capacitive Load Unit (pf): |

Time Unit: <~ From Ubrary - 1ns - 1ps - 10ps - 100ps

0K | Save... | Load... | Cancel | Help |

Fig. 5 Design import - timing dialogue box.

Not all the constraints in the file are actually supported in Encounter. In our case, only the clock
definition is actually imported.

The rest of the settings can be left as is. You can now save the updated configuration in the file
./b03.conf by clicking on the Save... button.

Finally, click on OK. The configuration is then read in.

In the case of the AMS design kit, a number of similar errors are reported when the LEF file is loaded.
The error message is like:

**ERROR: Macro '...' obs coordinate y value... isn't on manufacturing
grid.

It's likely result in placement/routing that can't be manufactured

The errors can be safely ignored. The violating coordinates belong to obstructions in the cell LEF file
that describe 45 degree shapes. These shapes are not on the manufacturing grid, but this is no problem
for the place & route flow. Finally the cells are replaced by the complete layouts anyhow.

To reload a configuration, select Design -> Design Import... in the main menu. Then, click on the
Load... button and load the configuration file from the ./PAR/CONF directory.



Global net connections

This step assigns pins or nets to global power and ground nets.
Select Floorplan -> Global Net Connections... in the main menu.

Global Het Connections M=l &3 I
— Connection List — Power Ground Connection

wddPIM:* vdd!Module() N — Connect
gnd!PIN:*.gnd!hodule()

4 Pins: |udd! |In Instances |*
~r Mets:

~~ Tie High
o Tie Low

— Scope
“* Under Module:

<l

~ Under Region: 0.0 0.0 0.0 n.a
~ Apply All

To Global Met: |vdd!
I Querride prior connection

[~ “erbose Qutput

7 Add to List | Update | Delete |
Apply | Check | Reset | Close | Help | |J

Fig. 6 Global net connections.

The left pane (Connection List) is initially empty. For each VDD and ground net:

* Check the Pins field and enter the pin name (vdd! or gnd!).

* Fill the To Global Net field with either vdd! or gnd!.

* Click on Add to List. The left pane now includes the related global net connection.
Click on Apply and Close.

Operating conditions definition

The operating conditions define the temperature, process and voltage conditions for the design. They
impact the timing calculations and optimizations.

Select the Timing -> Specify Analysis Conditions -> Specify Operating Condition/PVT... in the
main menu.



Specify Operating Condition M=l B

mact | min |

| Operating Condition Temp Proc Yolt m
Timing Library: c35_CORELIE I
BEST-MIL -50.0 0.64 3.6
BEST-IND -40.0 054 3.6
BEST 0.0 0.64 3.6
TYPICAL 25.0 1.0 3.3
WORST 759.0 1.4 3.0
WORST-IND g5.0 1.4 3.0
WORST-MIL 125.0 1.4 3.0
Cc35_CORELIBAHNOM_PYT 25.0 1.0 3.3 |

£

0K Reset | Cancel | Help |

Fig. 7

In the max tab, select the WORST-IND operating condition. In the min tab, select the BEST-IND
operating condition.

Click OK.
The max operating conditions will be used to meet setup timing constraints, while the min operating
conditions will be used to meet hold timing constraints.

Floorplan Specification

The floorplan defines the actual form, or aspect ratio, the layout will take, the global and detailed
routing grids, the rows to host the core cells and the I/O pad cells (if required), and the location of the
corner cells (if required).

Select Floorplan -> Specify Floorplan... in themain menu.



X Specify Floorplan [;] @
— Design Dimensions
apecify Dimensions by
“~ Bize hy:

“~ Core Size by: “~ Aspect Ratio: Ratio (H,-“Wj;l—1
<~ Core Wilization: Iw
.~ Std. Utilization: m

~ Width and Height:

~ Die Size by: Width and Height

Zzore Margins by: #~ Core to 10 Boundary
~ Core to Die Boundary

Core to Left; 16 Coreto Tnp:l 16
Core to Right:l 16 Core to Buttt:m:l 16

Die sSize Calculation Use: ~~- Maxt 10 Height -~ Min 10 Height
Floorplan Qrigin at; “~ Lower Left Comer - Center
~ Diefl0fCore Coordinates:
Die LL:| 0.0 | 0.0 UR; | 250.1 | 230.7
OLL| 0.0 | 0.0 UR:| 250.1 | 230.7
Core LL:| 50.4 | 50.7 UR:| 200.1 | 180.7
unit: micron

— Standard Cell Bows

Douhle-hack rows: E j Bottom row orient; :ﬂ

Fow Spacing: |II|.II| um ForEvery 2 —| Row
Row height: |15.0

— 10 Specifications

Bottom |2 Pad Crientation; [lnu —-|
OK | Apply | Cancel | Help |

Fig. 8

Define an aspect ratio of 1.
Set the core utilization to 85%, which means that 15% of the core area will be free for possible future

buffer insertions or cell replacements. The other utilization ratio (Std. Utilization) refers to the density
of the standard cells.
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Define I/O to core distances of 16 microns. This is enough since there won’t be any periphery cells (I/O
pads) in the layout. The cell rows will be abutted and flipped each two row to share VDD and ground
power rails.

Click OK.

The display design area pane now shows the defined floorplan with the required number of rows.

It is a good idea to save the design at that stage to allow restarting here quickly without needing to redo
all the previous steps. Select Design -> Save Design... in the main menu and save the current state in
the file cds_encouter_tutorial/b03.enc. The data is actually saved in the directory

cds_tutorial/b03.enc.dat.

To restore design data, select Design -> Restore Design... in the main menu and select the .enc file
to read in the cds_encounter_tutorial directory.

CAP cell placement

The AMS design kit requires that physical-only termination cells must be placed at each row ends. The
so called CAP cells are used to properly bias the P+ and N+ substrates.

Select Place -> Filler -> Add End Cap... in the main menu. Then, select the ENDCAPL cell as the
cell to place at the beginning of each row and the ENDCAPR cell as the cell to place at the end of each
TOW.

Click OK. The added cells are now visible in the Physical view (type <f> to redraw and fit the design
in the window) .

" AddEnd Cap lnstances _________ MEE)|
Pre Cap Cell |ENDCAPL Select |
Post Cap Cell |=NDCAPR Select |

Prefic |[ENDCAP

- Fill Area | Draw |

I [l
urx ury
oK ! cancel | Help | ||
Fig. 10
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Power ring/stripe creation and routing

This step generates the VDD and ground power rings around the core and optionally adds a number of
vertical and/or horizontal power stripes across the core. Stripes ensure a proper power distribution in
large cores.

Select Floorplan -> Power Planning -> Add Rings... in the main menu.
The Net(s) field defines the number and the kinds of rings from the core. In our case, there will be first

a ground ring around the core and a VDD ring around the ground ring. The net names should be
consistent with the power net names in the cell LEF file.

Add Rings =]

Basic | Advanced | Yia Generation |

Met(s): |gnd! wdd!

—Ring Typz
- Core Ring({s) contouring:

<~ Around core boundary ~ Along /O boundary

_I Exclude selected objects

~~ Block ring(s) around
o

<< <KL

|

~~ User defined coordinates

Mouse Clickl

s
W

— Ring Configuration

Top: Bottam: Left: Right:
Layer: METI H — METIH —| MET2ZV —-| MET2 ¥ —-|
Widit: |4 4 4 A ]
Spacing: |06 0.6 0.6 0E Update |
Offset.  “~ Centerin channel - Specify
07 0.7 0.7 07

0k ﬂ !ariahlesl Apply | Cancel | Qefault.sl Help |

Fig. 11

The ring configuration defines ring widths of 4 micron spaced by 0.6 micron. The rings will be placed
in the center of the channel between the core and the chip boundary (or the IO pads, if any).

It is possible to extend the ring segments to reach the core boundary. Click on the Advanced tab and
click on the segments you’d like to extend (see Fig.12). Other power and ground side trunks can be

defined by selecting only horizontal or vertical segments.

Click OK to generate the rings.
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Fig. 12

To add power stripes, select Floorplan -> Power Planning -> Add Stripes... in the main menu.

Add Stipes =]

Basic | Advanced | Yia Generation |

—3et Canfiguration
Met(s): gnd! wdd!

Layer: METZ —

Direction; #* Vertical .- Horizontal
Wiclth: 2
Spacing: |1 Update

—5et Pattern
~ 3Set-to-set distance: 100

“ Humber of sets: 1
- Bumps ~ ~

- Over PG pins Top pin layer — |

s
W W

—Stripe Boundary
“~ Core ring

-~ Pad Ring “ ~r

~ Design boundary r

~~ Each selected blockfdomainffence

-~ 8l domains

~- Specify area Draws...
0 0
1] 1]

—First / Last Stripe
“ Relative from core or selected area

® from left |6E| |
» from right: il

~ fhsolute locations

0 Point... |

0 Point... |

ok gan'ames| Apply | Cancel | gefaults| Help |

Fig. 13

The Net(s) field defines the pattern. Here a single pattern will be generated (select Number of sets and
insert 1). Each stripe will be 2 micron wide and the space between them will be 1 micron.
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Check Relative from core or selected area and enter the value 70 (micron) in the X from left field.
The two stripes will be vertically placed near the centre of the core. It is possible to measure sizes by
using the ruler (press ESC to remove all rulers).

Click OK to generate the stripes.

Now, it is possible to route the power grid. Select Route -> SRoute... in the main menu. All default
values are fine. Click OK to do the routing. The design now looks like below:
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It is recommended to save the new stage of the design. Select Design -> Save Design... in the main
menu and save the current state in the file cds_encounter_tutorial/b03.enc.

Core cell placement
This steps places the cells of the imported Verilog netlist in the rows.

Select Place -> Place... in the main menu.
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X Place (_] .:?(]
— Placement Effort Level
~.~ Prototyping

~ Low Effort

“ Medium Effort

- High Effort

I Timing Driven
I Save Mew Metlist to ?bDS.stt_tdp.u
1 lgnore Scan Connection

1 Ignore Spare Cell Connection

_| Save Placement to [bDS.pIace J
oK | Cancel Help I
Fig. 15

Select the Timing Driven option. This is only valid if timing constraints have been properly defined on
the design. This option will optimize the placement of the cells that are on the critical path.

Click OK to do the placement. It may take some time to complete, especially when the placement is
timing driven.

Clock tree synthesis (optional)

As the paths that will propagate the clock signal in the design are not necessarily balanced, some
registers may receive the active clock edge later than others (clock skew) and may therefore violate the
assumed synchronous design operation. For example, the original clock tree we can get from the
previously placed design is:

# FirstEncounter (TM) Clock Synthesis Technology File Format
# for automatic gated clock tree synthesis

# AutoCTSRootPin <clock root pin names
# MaxDelay <number>

# MinDelay <number>

# SinkMaxTran <number>

# BufMaxTran <number>

# MaxSkew <number>

# NoGating <rising|falling|NO>

# MaxDepth <number >

# Buffer <cell 1> <cell 2> <cell 3>
# LeafPin

# + <pin name> <rising|falling>

# + ...

# LeafPort

# + <port name> <rising|fallings>

# + ..

# ExcludedPin

# + <pin name>

# + ..

# ExcludedPort

15



# + <port name>

# + .

# End

#

AutoCTSRootPin clock
NoGating rising
MaxDelay 3ns
MinDelay Ons
MaxSkew 150ps
SinkMaxTran 400ps
BufMaxTran 400ps
Buffer BUF2 INVO

End
You will see the following data in the train.cts.auto file:

o The clock root name is clock.
o The max and min insertion delays are specified as 3 and 0 ns.
o The transition on clock nets is specified as 400 ps, while the clock skew is 150 ps.

The NoGating option instructs the clock tree generation tool to stop at nonbuffer/noninverter pins and
to use the specified edge as the trigger edge.
If you have more internal clocks, add their information to the specification file.

In order to load the clock tree specification file select Clock -> Specify Clock Tree... in the main
menu and select the file ../b03.cts.auto that has been previously created.

N Specify Clock Tree =) (%]
— Specification Selection
Clock Tree File:  |./b03.cts.auto El
oK | apply Cancel | Help
Fig. 21

To create the clock tree, select Clock -> Sythesize Clock Tree ... in the main menu.
Define the result directory as b03_cts and the base file name as b03_cts.
Click OK to create the clock tree.
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X Synthesize Clock Tree !

— Clock Tree Synthesis
[T Set Added Clock Buffers as Fixed

I Handle Clock Crossover and Eeconvergence

—Clock Tree Results
[T Save Metlist

[~ Save Placement

[T Save Clock Tree Synthesis Report
[T Zave Clock Tree Fouting Guide

_1 Save Clock Tree tMacro MModel

[~ Save Clock Mets

Fesult Directory: %IbEIS_cts
Base File Name; §bD3_ct5 I
oK apply Cancel Help
Fig. 22

Now it is possible to run timing optimization based on the generated clock tree. Select Timing ->
Optimization... in the main menu and check PostCTS. Click OK to do the optimization.

optimizaion @B
hMode: - precTs . postCTS ~ postRoute _I incremental
Effort; “* High - Lowr

— Type
[~ Setup I Fold |
[~ Design Rule Violations [~ Max Cap T Max Tran I hdax Fanout

— Path Group
< Al -~ RegZRey ~- InZReg ~ Regzout ~ InZout

— Cptions
Target Zlack:  Setup Time 0.0 0o
Ivlax Density |0.95 DRY hargin 0.0
o Useful Skew I | oo

| o
OK ‘l Apply Advanced... Cancel Help
Fig. 23

The console will display the results of the timing optimization:

Setup mode
Worst Slack:
TNS: 0.000ns

0.000ns

Violating Paths: 0
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Pathgroup Slacks

reg2reg: 0.000ns

in2reg: 0.000ns

reg2out: 0.000ns

in2out: 0.000ns
Density: 71,649%
Routing Overflow: 0.00% H and 0.00% V
Real DRV (fanout, cap, tran): (0, 0, 0)
Total DRV (fanout, cap, tran): (0, 0, 0)
**optDesign ... cpu = 0:0:0, real = 0:0:0, mem = 102.1M **
*** Finished optDesign ***

Filler cells

Filler cells will fill remaining holes in the rows and ensure the continuity of power/ground rails and
N+/P+ wells in the row.

To fill the holes with filler cells, select Place -> Filler -> Add Filler... in the main menu. Select the
cells FILL1, FILL2, FILL5, FILL10, and FILL25 and click OK to place the filler cells.

Do not add filler cells now if you intend to synthesize a clock tree. Clock tree synthesis may need some
free space to insert clock buffers to balance the clock paths.

Add Filler I = S |

Cell Mame(s) |FILL1 FILLZFILLS FILL1  Select |
Prefix |FILLER
[~ Fill Boundary
_I Fill area Draw
s 1%
urx ury
oK ‘,! Cancel | Help

Fig. 16

The placement should then look like below (redraw <f> the image if it was not updated):
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Design routing

This steps generates all the wires required to connect the cells according to the imported gate-level
netlist.

To route the design, select Route -> Nanoroute... in the main menu, check the Timing Driven box and
click OK to do the routing. You now get the routed design:
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Timing analysis

Select Timing -> Timing Analysis... in the main menu. Define the path for the slack report file. Click
OK.
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X Timing Analysis [_;| @
— Timing Analysis hode

Setup/Hold
“~ Setup Time Analysis

+ Hold Time Analysis

Mo Async/Async .
“~ With Asynchronous Check

~ Mo Asynchronous Check

~ Asynchronous Check Only

Mo Skew Skew
+ Mo Skew Analysis

“~ Skew Analysis

Mo ClockTree/ClockTree ;
“~ futo Detect

+ Mo Cock Tree

~ Clock Tree Exist

_| lgnore MNet Load

Slack Report File: b03.slk
[~ Detailed Yiolation Report File: EbDS.tarpt
Mumber of Violations To Report . EED

0K | Cancel Help |

Fig. 18

In the console window you get a summary of the timing analysis and the slack report file includes more
detailed information.

Right after the placement it is also possible to get a first report on the design timing with the same
procedure.

Design checks

The Verify menu has a number of items to check that the design has been properly placed and routed.
Select Verify -> Verify Connectivity... in the main menu.
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X Verify Connectivity E] @

Met Type
S |

~~ Hegular Only

~ Special Only

~Mets
<~ Al
~ oelected
~ Mamed:

—Check
I~ Cpen I UnConnected Pin

_| Connectivity Loop I Antenna
| GGeometry Loop

Yerify Connectivity Repaort: IbDE.cnnn.rpt

Fepaort Limits
’Errur:hDDD Wyarning: |50

ok | apply | cancer | Help |

Fig. 25

Define the report file as ./RPT/b03-conn.rpt. Click OK. The console displays the results. Confirm that
there are no violations or warnings.

Select Verify -> Verify Geometry... in the main menu.
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Yerify Geomely =] E3

Basic | Acvanced |

— YWerification Area
#~ Entire area

~ Specify Draw | View Area
0 0
a 1]

— Check
[~ bdinimum Width [~ Minimum Spacing

[~ Minimum Area [~ Same Met Spacing

[~ Shaort _I Geometry Antena

[~ Cell Qverlap I Off Routing Gric

I~ Insufficient hdetal Querlap I~ Off Manufacturing Grid

—Alowy

Pin In Blockage

Same Cell Violations

Different Cell Violations

Owerlap of Pad Filler Cells

Cwerlap of Routing Blockages And Pins

[ R Y S

Overlap of Routing Blockage And Cell Blockage

ok W apply Gancel Help | |

Fig. 26

In the Advanced tab, define the report file as b03.rpt. Click OK. The console displays the results.

Report generation

A number of reports have been already generated in the previous steps. They should be located in the
working directory. The Tools menu includes some additional reports, try:

Tools -> Netlist Stats

Tools -> Gate Count Report...

Tools -> Summary Report...

in order to obtain different types of statistical information.

Post-route timing data extraction

This step generates the post-route SDF (Standard Delay Format) file that includes both the actual
interconnect and cell timing delays.

The parasitics must be first extracted. Select Timing -> Extract RC... in the main menu.

The generated Cap file includes the wired capacitance, pin capacitance, total capacitance, net length,
wire cap per unit length and the fanout of each net in the design.

The generated SPEF (Standard Parasitics Exchange Format) file includes RC values in a SPICE-like
format.

The SDF file may be then generated by selecting Timing -> Calculate Delay... in the main menu.
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The checked Ideal Clock switch means that flip-flops are considered as having Ops rising and falling
transition times.

Post-route netlist generation

This steps generates a Verilog netlist of the routed design. The netlist may be different from the
imported netlist as cells may have been added or replaced during clock tree synthesis and timing-driven
optimizations.

Select Design -> Save -> Netlist... in the main menu.

The generated file should saved into the HDL/GATE directory.

% save Netlist (=] (]

I | i)

7 Include Intermediate Cell Definition
[T Include Leaf Cell Definition
Metlist File: %EDS_muted.u

oK Cancel Help |

Fig. 31

GDS2 file generation

The placed and routed design can be exported in different formats for further processing outside the
Encounter tool. The GDS2 binary format is a standard format for integrating the block in the top-level
layout, doing DRC/LVS checkings, or delivering the layout to the foundry.

To export the design in the GDS2 format, select Design -> Save -> GDS... in the main menu.

The GDS map file has been copied by the AMS setup script in the DEX directory. The generated GDS2
file is written in the same directory.
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Fig. 32

Design import in Virtuoso

The GDS?2 file can be imported in Virtuoso for further processing. To do that, it is recommended to
start the Cadence IC environment in the LAY directory.

Start Cadence IC:
ams_cds -t ¢35b3 -m fb

Create a new library called bO3 with the attached technology file TECH_C35B3.

In the DFII shell, select File -> Import -> Stream....
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Fig. 34

In the Options tab, check the Retain Reference Library (No Merge) option. Since the cell layouts are
available in the CORELIB library, it is possible to display the full layout of the block.
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Using scripts (optional)

It is much more convenient to capture the placement and routing flow in a script. Cadence Encounter
also support sthe Tcl language for building scripts.

An example of such a script for placement and routing is presented next.

To run a Tel script, execute the following command in a Unix shell:

>encounter script name.tcl

The example given below may be modified to define design information and to control the flow to
some extent.

Cadence Encounter Tcl script for adder-subtractor.

Process: AMS 0.35u CMOS (C35), Hit-Kit 3.70

It is assumed that a project directory structure has already been
created using 'create project' and that this synthesis script is
executed from the project root directory $PROJECT DIR

set PROJECT_DIR [pwd]

#

Design related information (can be changed)

set DESIGN addsub_nbits8
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set
set
set

TIM LIBRARY C35 CORELIB
TIM_OC_MAX WORST ;# TYPICAL | WORST | WORST-TIND
TIM OC_MIN BEST ;# TYPICAL | BEST | BEST-IND

# Floorplan settings

#

set
set
set

FP_ASPECT RATIO 1
FP_ROW DENSITY 0.85 ;# percent
FP_CORE2IO 16 ;# micron

# Power ring and settings

#

set
set
set
set

PR _WIDTH 4 ;# micron

PR _SPACING 1 ;# micron

PR_LAYER TB MET1 ;# top and bottom layer
PR_LAYER LR MET2 ;# left and right layer

# Power stripe settings

#

set
set
set
set
set
set

ST NUM_SETS 1 ;# number of sets
ST SPACING 1 ;# micron

ST LAYER V $PR_LAYER LR

ST WIDTH 2 ;# micron

ST_XOFS_R 60 ;# micron
ST_XOFS_L 60 ;# micron

# Placement settings

#

set

PL_EFFORT -high ;# -low | -medium | -high

# Clock tree synthesis settings

#
set
set

#
#
#
#
#
#
#
#
#
#
#
#
#
#

CTS_BUFFER BUF2
CTS_INV INVO

Flags that drive the script behavior (can be changed)

ADD_STRIPES (0 | 1)

if 1, add stripes

PLACE _TIMING (0 | 1)

if 1, do a timing driven placement

CLOCK_TREE (0 | 1)

if 1, create a clock tree

CTS_CREATE SPEC (0 | 1)

if 1, create a clock tree specification file with default values
ROUTE_TIMING (0 | 1)

if 1, do a timing driven routing

OPT (string)

can be used to have different generated file names

ADD_STRIPES 1
PLACE TIMING 1
CLOCK_TREE 1
CTS_CREATE_SPEC 0
ROUTE_TIMING 1
OPT " cts"

CONF_FILE NAME ${DESIGN}.conf

DESIGN NAME ${DESIGN}${OPT}

SAVE DESIGN FP NAME ${DESIGN NAME}-fplan.enc

SAVE DESIGN PR NAME ${DESIGN NAME}-pring.enc

SAVE DESIGN PL NAME ${DESIGN NAME}-placed.enc

SAVE DESIGN PF NAME ${DESIGN NAME}-placed filled.enc
}
}

el lenn)

SAVE DESIGN CT NAME ${DESIGN NAME}-cts.enc
SAVE DESIGN RO NAME ${DESIGN NAME}-routed.enc
TIM RCDB NAME ${DESIGN NAME}.rcdb

SDF_FILE NAME ${DESIGN NAME}-routed.sdf
SPEF_FILE NAME ${DESIGN NAME}-routed.spef

RPT CHECK TA NAME ${DESIGN NAME}-checkta.rpt
RPT REPORT TA NAME ${DESIGN NAME}-ta.rpt

RPT SLACK NAME ${DESIGN NAME}-slack.rpt
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RPT GATE COUNT NAME ${DESIGN NAME}-gate count.rpt
RPT NOTCH NAME ${DESIGN NAME}-notch.rpt

RPT CONN NAME ${DESIGN NAME}-conn.rpt

RPT GEOM NAME ${DESIGN NAME}-geom.rpt

RPT DENSITY NAME ${DESIGN NAME}-density.rpt
VLOG_NETLIST SIM NAME ${DESIGN NAME}-routed.v
VLOG NETLIST LVS NAME ${DESIGN NAME}-routed lvs.v
CTS_SPEC NAME ${DESIGN NAME}-spec.cts

CTS_RGUIDE NAME ${DESIGN NAME}-guide.cts

CTS_RPT NAME ${DESIGN NAME}-cts.rpt

GDS_FILE NAME ${DESIGN NAME}.gds

CONF_FILE ${PROJECT DIR}/PAR/CONF/${CONF FILE NAME}

SAVE DESIGN FP FILE ${PROJECT DIR}/PAR/DB/${SAVE DESIGN FP NAME}

SAVE DESIGN PR FILE ${PROJECT DIR}/PAR/DB/${SAVE DESIGN PR NAME}

SAVE DESIGN PL FILE ${PROJECT DIR}/PAR/DB/S${SAVE DESIGN PL NAME}

SAVE_DESIGN PF FILE ${PROJECT DIR}/PAR/DB/${SAVE DESIGN PF NAME}
} }
} }

el el
Ll lann)

SAVE DESIGN CT FILE ${PROJECT DIR}/PAR/DB/${SAVE DESIGN CT NAME

SAVE DESIGN RO FILE ${PROJECT DIR}/PAR/DB/S${SAVE DESIGN RO NAME
SDF_FILE ${PROJECT DIR}/PAR/TIM/${SDF_FILE NAME}

SPEF FILE ${PROJECT DIR}/PAR/TIM/${SPEF FILE NAME}

TIM RCDB FILE ${PROJECT DIR}/PAR/TIM/${TIM RCDB NAME}

RPT CHECK TA FILE ${PROJECT DIR}/PAR/RPT/${RPT CHECK TA NAME}

RPT REPORT TA FILE ${PROJECT DIR}/PAR/RPT/${RPT REPORT TA NAME}

RPT SLACK FILE ${PROJECT DIR}/PAR/RPT/${RPT SLACK NAME}

RPT GATE COUNT_FILE ${PROJECT DIR}/PAR/RPT/${RPT GATE COUNT NAME }

RPT NOTCH FILE ${PROJECT DIR}/PAR/RPT/${RPT NOTCH NAME}

RPT CONN_FILE ${PROJECT DIR}/PAR/RPT/${RPT CONN_ NAME}

RPT GEOM FILE ${PROJECT DIR}/PAR/RPT/${RPT GEOM NAME}

RPT DENSITY FILE ${PROJECT DIR}/PAR/RPT/${RPT DENSITY NAME}
VLOG_NETLIST SIM FILE ${PROJECT DIR}/HDL/GATE/S${VLOG NETLIST SIM NAME}
VLOG_NETLIST LVS FILE ${PROJECT DIR}/HDL/GATE/${VLOG NETLIST LVS NAME }
CTS_SPEC_FILE ${PROJECT DIR}/PAR/CTS/${CTS_ SPEC_ NAME}

CTS_RGUIDE_FILE ${PROJECT DIR}/PAR/CTS/${CTS RGUIDE NAME}

CTS _RPT FILE ${PROJECT DIR}/PAR/RPT/${CTS RPT NAME}

GDS_FILE ${PROJECT DIR}/PAR/DEX/${GDS_FILE NAME}

GDS_MAP FILE ${PROJECT DIR}/PAR/DEX/gds2.map

# make_clock_tree

#

proc make clock tree create spec {

global CTS BUFFER CTS INV CTS SPEC_FILE CTS RGUIDE _FILE CTS RPT FILE
if { Screate spec || !l[file exists $CTS _SPEC FILE] } ({
createClockTreeSpec \

-bufFootprint $CTS_ BUFFER \

-invFootprint S$CTS_INV \

-output $CTS_SPEC FILE

}

specifyClockTree -clkfile $CTS SPEC FILE
ckSynthesis \

-rguide $CTS_RGUIDE FILE \

-report $CTS RPT FILE

optDesign -postCTS -setup -drv -outDir PAR/RPT
} i# make clock tree

B o o o
# Load configuration file

B o o o o
loadConfig $CONF_FILE 0

commitConfig

B o o o o
# Set operating conditions

B o o o

setOpCond \
-maxLibrary $TIM LIBRARY -max $TIM OC MAX \
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-minLibrary $TIM LIBRARY -min $TIM OC MIN

B o o C o o .
# Set user grids

B o o C C o .
setPreference ConstraintUserXGrid 0.1

setPreference ConstraintUserXOffset 0.1

setPreference ConstraintUserY¥YGrid 0.1

setPreference ConstraintUserYOffset 0.1

setPreference SnapAllCorners 1

setPreference BlockSnapRule 2

B o oo o o e .
# Define global Power nets - make global connections

B o oo o o e
clearGlobalNets

globalNetConnect vdd! -type pgpin -pin vdd! -inst * -module {} -verbose
globalNetConnect gnd! -type pgpin -pin gnd! -inst * -module {} -verbose
#globalNetConnect vdd3o! -type pgpin -pin vdd3o! -inst * -module {} -verbose
#globalNetConnect vdd3rl! -type pgpin -pin vdd3rl! -inst * -module {} -verbose
#globalNetConnect vdd3r2! -type pgpin -pin vdd3r2! -inst * -module {} -verbose
#globalNetConnect gnd3o! -type pgpin -pin gnd3o! -inst * -module {} -verbose
#globalNetConnect gnd3r! -type pgpin -pin gnd3r! -inst * -module {} -verbose

floorPlan -r $FP_ASPECT RATIO \

$FP_ROW DENSITY \

SFP_CORE2IO S$FP_CORE2IO $FP_CORE2IO $FP_CORE2IO
fit

saveDesign $SAVE DESIGN FP FILE

addRing \

-around core \

-nets { gnd! vdd! } \

-width bottom $PR WIDTH -width top $PR_WIDTH \

-width left $PR WIDTH -width right $PR_WIDTH \
-spacing bottom $PR_SPACING -spacing top $PR_SPACING \
-spacing left $PR_SPACING -spacing right $PR SPACING \
-layer bottom $PR_LAYER TB -layer top $PR_LAYER TB \
-layer left $PR _LAYER LR -layer right $PR_LAYER IR \
-center 1 \

-t1 1 -tr 1 -b1 1 -br 1 -1t 1 -1b 1 -rt 1 -rb 1 \
-stacked via bottom layer MET1 -stacked via top layer MET4 \
-threshold 0.7

if { $ADD STRIPES } {

addStripe \

-nets { gnd! vdd! } \

-number of sets $ST NUM_SETS \

-spacing $ST SPACING \

-layer $ST LAYER V \

-width $ST WIDTH \

-xleft offset $ST XOFS L

}

sroute \

-jogControl { preferWithChanges differentLayer } \
-nets { gnd! vdd! }

saveDesign $SAVE DESIGN PR FILE

if { $PLACE TIMING } ({
amoebaPlace $PL_EFFORT -timingdriven
} else {
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amoebaPlace $PL_EFFORT
setDrawMode place
saveDesign $SAVE DESIGN PL_FILE

# Create clock tree (optional)

if { SCLOCK TREE } ({
make clock tree $CTS_ CREATE SPEC
saveDesign $SAVE DESIGN CT FILE

addFiller -cell FILL25 FILL10 FILL5 FILL2 FILL1l -prefix FILLER
saveDesign $SAVE DESIGN PF FILE

if { $ROUTE TIMING } ({

setNanoRouteMode -quiet -timingEngine CTE
setNanoRouteMode -quiet -routeWithTimingDriven true
setNanoRouteMode -quiet -routeTdrEffort 0

globalDetailRoute

optDesign -postRoute -setup -drv -outDir PAR/RPT
saveDesign $SAVE DESIGN RO FILE

setDrawMode place

fillNotch -report $RPT NOTCH FILE
verifyConnectivity \

-type all \

-error 1000 \

-warning 50 \

-report $SRPT CONN FILE
verifyGeometry \
-allowSameCellViols \
-allowRoutingBlkgPinOverlap \
-allowRoutingCellBlkgOverlap \
-report $RPT_GEOM FILE
verifyMetalDensity \

-detailed \

-report $RPT _DENSITY FILE

setExtractRCMode \
-detail \

-rcdb $TIM RCDB_FILE \
-relative ¢ t 0.01 \
-total ¢ t 5.0 \
-reduce 5

extractRC

rcOut -spef $SPEF_FILE
delayCal -sdf $SDF _FILE

reportGateCount -outfile $RPT GATE COUNT FILE

# Timings

#

setCteReport

setAnalysisMode -setup -async -skew -noClockTree -sequentialConstProp
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reportAnalysisMode

buildTimingGraph

checkTA -verbose > $RPT CHECK TA FILE

reportTA \

-format { hpin arc cell delay arrival required slew fanout load } \
-late \

-max_points 10 \

-net \

> $RPT_REPORT TA FILE

saveNetlist -excludeLeafCell $VLOG NETLIST SIM FILE
saveNetlist -physical $VLOG NETLIST LVS FILE

streamOut $GDS _FILE \
-mapFile $GDS MAP FILE \
-1libName ADDSUB \
-structureName $DESIGN NAME \
-stripes $ST NUM_SETS \
-units 1000 \

-mode ALL
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